Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to Install " The Finite Element Toolkit " in Ubuntu 12.04.

Downloaded the source file (tar.gz) for version 1.5 from here

It has got a script to install all the tools that come with it, so when i run the script which in turn calls the ./configure script and it checks for missing and required dependencies.

And it stops with an error as "GL libraries missing BUT REQUIRED.. EXITING ON ERROR"

---------- begin processing APP configure options ----------
checking whether you want pedantic ANSI compilation... no
checking whether you want profiling... no
checking whether you want ElectricFence... no
checking whether your environment defines FETK_MOTIF_LIBRARY... no
checking for XmGetColors in -lXm... no
Motif library missing but not required ...rocking on...
checking whether your environment defines FETK_GL_LIBRARY... no
checking whether you need the MacOSX hack for OpenGL... no
checking for glPushMatrix in -lGL... no
configure: error: GL library missing but REQUIRED...EXITING ON ERROR
make: *** No rule to make target `install'.  Stop.
~/Desktop/fetk
---------------------- FETK-BUILD: STOPPING ----------------------

While i have installed almost most of the Graphical library packages like freeglut3, freeglut3-dev, libglib-mesa, etc., still the same error.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.