Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

hello i'm new to linux

i'm using Toshiba c850 notebook and i can't install ' intel HD graphics 3000 ' driver on ubuntu 12.04.1 LTS (32 bit)

the problem is when i play HD movies , video is not smoothly playing. and every time i boot up my notebook on ubuntu i have to adjust my screen goes maximum level every time i restart my notebook.but in windows it works fine and HD videos play smoothly.

please help friends. Thanks

share|improve this question

Welcome to askubuntu. To get helpful answer you need to follow few points,

  • First thing, you should not club many question at one question. Read [FAQ]
  • Second thing, post hardware details as much as possible. We don't own the device. Google search will reveal many model with the same name.
  • Last, search before you post.

Back to answers

a) Intel Grpahics card drivers are open sourced and in inbuilt in kernel. So ubuntu doesn't require installation of these driver. Run dpkg -s xserver-xorg-video-intel to check the status of the driver package: it should be installed.

b) brightness issue:

  1. If your brigtness key not working . try following else skip to step 2

    execute sudo gedit /etc/default/grub

    Change this line

    GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

    to something like below

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

    Execute sudo update-grub and reboot . See if brightness keys are working.

  2. It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.

    Try following for paths shown by ls /sys/class/backlight/*/brightness and replace accordingly.

    example paths will be like


    1. For the above path Get the maximum brightness:

    cat /sys/class/backlight/acpi_video0/max_brightness

    Try a lower value to set the brightness, say output is 16 so I will try with half of it

    echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

    If this works, make this happen in each login automatically by doing the following

    sudo gedit /etc/rc.local

    Enter this line just before exit 0. It should look like

    echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness exit 0

  3. HD video issue. Try a different player like vlc. If the problem is there you may want to update drivers from xorg-edgers ppa. Though generally it doesn't require & intel HD can play HD videos without any extra update. See How do I install drivers for an Intel HD Graphics?

share|improve this answer
thanks for your help.brightness issue is now ok.but Intel HD Graphics issue is still there.i tried using VLC and Totem Movie player.and i xorg drivers using these commands sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update && sudo apt-get upgrade but issue is still there. – Gayan Sampath Vidyarathne Dec 24 '12 at 14:58
i installed xrog drivers* using these --> sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update && sudo apt-get upgrade – Gayan Sampath Vidyarathne Dec 24 '12 at 15:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.