Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a recent Ubuntu migrant (I was running windows 7 until early this year) and I think I'm having some issues with my graphics. I did a fresh 12.04 64 bit install on a new build, the specs of which are:

ASRock Z77 Pro3
Intel i5 3470 (with integrated Ivy Bridge HD2500 graphics)
Intel 330 series 120gb SSD (boot)
8gb ram

I initially found out something was wrong when I tried to start Minecraft for the first time and it crashed after I attempted to login, giving me the following error:

X Error - disp: 0x7f36b000e0c0 serial: 31 error: BadRequest (invalid request code or no such operation) request_code: 136 minor_code: 14

To get minecraft working, I followed suggestions like updating the lwjgl, which didn't affect the error in minecraft. Further reading suggested a issue with my graphics so I updated the x drivers for intel and mesa utils, but glxinfo still gives a similar output to the error in minecraft:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

lspci recognises the graphics controller as VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)

but the system details under 'Settings' displays the graphics drivers as blank.

I am also unable to login to Unity 3d, even though I select "Ubuntu" at the login menu, it boots to unity 2d regardless (there's no option available for me to change the launcher icon size which I believe is a feature of Unity 3d).

As background to my issue (in case it is relevant), the fresh install of 12.04 on the new build wasn't without problems. My liveusb booted with graphics glitches similar to this person so I had to boot with nomodeset in the grub boot menu to do the install. The glitches were still there when I booted to the install though, so I followed suggestions to modify my grub config to always boot with nomodeset. I've since reversed what I did to the grub config file (edited out the nomodeset option and did 'update-grub') as I read that an update would cure my graphics glitch issues (and it seems to have).

I had a previous install of 12.04 running on my laptop and I wanted to migrate my settings over, so I backed up my laptop's home folder using Deja Dup and restored it to my destop installation as per a suggestion I found. This worked quite well with a few adjustments that had to be made (e.g. update file system references in deluge).

I've done a lot of searching to see if I could solve this issue myself and save having to post a question, but so far I think my limited familiarity with Ubuntu and Linux is letting me down. Please let me know if you need any additional info and I appreciate any help you can offer a noob.

share|improve this question
    
what is your kernel version, post result of uname -a –  Web-E Dec 24 '12 at 6:00
    
The interesting logs are dmesg and /var/log/Xorg.0.log; without those it's much harder to help you. You should be able to stick them in paste.ubuntu.com and link from here. –  RAOF Dec 24 '12 at 6:34
    
Kernal version: Linux gruntmaster 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux dmesg: paste.ubuntu.com/1461266 Xorg.0.log: paste.ubuntu.com/1461267 –  Trung Dec 24 '12 at 6:42
add comment

1 Answer 1

I managed to fix my issue. First, after poking around I decided to update my kernel to the mainline 3.7.0 kernel in case the issue was due to hardware incompatibility. It still didn't work out so I kept looking and found that people were having graphics driver issues when they had proprietary ati drivers installed. This hadn't occurred to me, because I didn't think these would be on my system at all (would the drivers have been migrated over when I transferred my home folder from my laptop?) but sure enough I found the fglrx driver installed.

Once I purged and rebooted, I'm greeted with launcher icons stacking on top of each other and the ability to finally load up Steam!

So the fglrx drivers were definitely giving me trouble, but I can't confirm if the integrated graphics weren't supported in 3.2.0-35-generic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.