Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.10 and having trouble with the audio output through HDMI on my Acer Aspire one 722. It's using an AMD c-60. I was able to add in the radeon.audio=1 kernel parameter, which was supposed to enable HDMI audio playback but even after running update-grub and rebooting, the problem persists when I choose HDMI as the audio output after plugging in my HDMI cable.

At this point, I'm not sure what else to do.

share|improve this question

2 Answers 2

You may need to install the actual proprietary drivers for your Radeon card to get HDMI audio working properly. Also pavucontrol allows you to tweak the audio settings much better than the default volume control.

In a Terminal window type these commands:

cd /tmp && wget -O amd-driver-12-6-x86_64.run http://www2.ati.com/drivers/linux/amd-driver-installer-12-6-x86.x86_64.run
chmod +x amd-driver-12-6-x86_64.run
sudo sh amd-driver-12-6-x86_64.run

sudo aticonfig --initial -f

The last command will let you know if installation worked OK.

share|improve this answer
    
I was thinking about that but last time I installed proprietary drivers, it disabled sleep mode for my laptop. Will the same happen here? –  Jexams Dec 24 '12 at 18:31

radeon.audio=1 seemed to work for me, but I noticed you said you ran update-grub... It probably overwrote the setting with the defaults once again. (caught that when I also ran update-grub)

Hope it helps :D

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.