Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I downloaded many .tars (lame, faad, libmpeg, xvid...)* then extracted them passed on --prefix flag such that they were all neatly installed in respective /opt/bin, /opt/include, /opt/lib. Then I tested each executable & they were working fine. Some of them too were made symlinked in /usr/bin & everything worked fine.

*previously only faac was installed by default in /usr/bin

Now I don't want ffmpeg because back in windows I always used x264 syntax with custom patches a good example is https://github.com/astrataro/x264_tMod

The problem while compiling x264 is that it doesn't recognize the newly installed audio codecs in /opt it only recognises the faac which previously was installed default to /usr I tried symlinking but x264 doesnt pick them up? Though I can access every function of executable properly from terminal?

./configure --enable-nonfree --enable-shared --disable-opencl --prefix=/opt
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
platform:      X86
system:        LINUX
cli:           yes
libx264:       internal
shared:        yes
static:        no
asm:           yes
interlaced:    yes
avs:           no
lavf:          no
ffms:          no
avi output:    no
audio:         yes (raw, faac)
gpl:           yes
nonfree:       yes
thread:        posix
filters:       crop select_every hqdn3d pad vflip subtitles yadif
debug:         no
gprof:         no
strip:         no
LTO:           no
PIC:           no
visualize:     no
bit depth:     8
chroma format: all
opencl:        no

as you can see only faac is picked up is there any method to direct x264 to know that it had to pick other libraries from /opt ?

share|improve this question
I think you should also INCLUDE the parent directory of the manually installed codecs into ./configure. Type: ./configure --help to see the available options. –  nickanor Dec 24 '12 at 6:36
plz guide me thither upon doing such a thing... –  nightcrawler Dec 24 '12 at 7:23
I havent done that but i'm sure its included in compile options –  nickanor Dec 24 '12 at 7:37
sir what do you mean by parent directory of installed ones? –  nightcrawler Dec 24 '12 at 8:31
My final answer if you still did not get it compile correctly. You said that your installed codecs are located in /opt/ and there's an INCLUDE folder in it. That means the needed libraries/headers that x264 needed to detect your codecs are located in /opt/include/ as i would expect and you have to include that INCLUDE folder to ./configure options, --help for more options. If still does not work, revert installation of your codecs and install it from any of of these apps: apt-get, synaptic, or software center. Then recompile your x264. –  nickanor Dec 24 '12 at 9:33
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.