Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I add a boot parameter?

I'm using an Acer Aspire one 722 with Ubuntu 12.10 (32 bit).

I've been having problems with getting audio to play over HDMI and after some searching around, I found that I have edit the kernel parameter so that it reflects radeon.audio=1, which will enable audio over HDMI.

My problem is that I don't know how to make that fix.

share|improve this question
add comment

marked as duplicate by Jorge Castro, Ringtail, Eliah Kagan, devav2, fossfreedom Dec 24 '12 at 10:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

you will need to be root for the following.

you have to edit your grub config. open /etc/default/grub with your preferred text editor and look for GRUB_CMDLINE_LINUX_DEFAULT and add radeon.audio=1 to the end of it.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

becomes

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

now save the file and run update-grub

you may also want to try to add this parameters at boot time to ensure it works before doing all of the above. after you power on you may need to hold Shift to get the grub menu to appear after it appears press e and add radeon.audio=1 to the end of a line similar to this

linux /boot/vmlinuz-2.6.38-8-server root=UUID=11111 ro quiet splash

becomes

linux /boot/vmlinuz-2.6.38-8-server root=UUID=11111 ro quiet splash radeon.audio=1

and press b to boot with the added parameter

share|improve this answer
    
Thanks! Sadly, audio still isn't working for some reason though. –  Jexams Dec 24 '12 at 5:28
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.