Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When you right click on a Linux desktop, a menu appears which contains entries like "New folder", "Change desktop background", "Paste", "Scripts", etc. But on a fresh install in Ubuntu 12.10, the "Scripts" option is not showing. I suspect it has something to do with the updated "Nautilus File Manager" software. Is it possible to turn on the script option so that I can execute scripts with a single click? Thank you ...

share|improve this question
    
you just want to edit the right-click menu? –  madmaze Dec 23 '12 at 22:36
add comment

2 Answers

I had the same problem in ubuntu 12.10 running Gnome nautilus 3.6.3

Scripts not showing in right click menu

  • Try and place your scripts in the /home/username/.local/share/nautilus/scripts directory
  • Allow script to be run by nautilus with the command sudo chmod +x filename_of_script
  • Now Reboot to reload nautilus

This should enable scripts when right clicking on a folder or a file.

Create New File not showing in right click menu
open gedit with sudo gedit
when the blank document is open in gedit press "file" then "save as"
store the blank file in the /home/username/Template folder, save it as "Empty File"
Now Reboot to reload nautilus
This should enable "New Document" > "Empty file" when right clicking in folder/on desktop

I am trying to get scripts showing on desktop right click, if i manage i will post an update.
I Hope my answer helped you out

share|improve this answer
    
This solution for scripts not showing in right click menu works for Nautilus 3.8.x as well –  Freedom_Ben Aug 30 '13 at 20:21
add comment

Scripts menu(on right-click popup menu) will appear if you add some scripts file to ~/.gnome2/nautilus-scripts.You can install Ubuntu Tweak and you can add some certain scripts to this director easily or add your script's file to this folder.

share|improve this answer
1  
This only works for Nautilus < 3.6 for Nautilus >= 3.6 place scripts into ~/.local/share/nautilus/scripts –  user22153 Aug 7 '13 at 9:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.