Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There seems to be something broken with the Ubuntu Software Center (or at least my install of it), and what ever it is also effects some other internet-connected native ubuntu apps (Ubuntu Tweak, Nuvola Player, and Lightread (although lightread doesn't give the error message)).

When I try to install a free app that goes through the payment service (as in one that you 'buy' for $0.00), or a paid app, in the Software Center, I get this message:

*Unable to load page Problem occurred while loading the URL https://software-center.ubuntu.com/subscriptions/en/ubuntu/quantal/+new/?archive_id=commercial-ppa-uploaders%2Fstormcloud&arch=amd64 Cannot resolve hostname (software-center.ubuntu.com)*

Nuvola gives me a similar message:

Unable to load page Problem occurred while loading the URL http://8tracks.com/ Cannot resolve hostname (8tracks.com)

And Ubuntu Tweak gives:

Unable to load page Problem occurred while loading the URL (I have to put this text here so it's not more than two hyperlinks in the post)http://ubuntu-tweak.com/utapp/ Cannot resolve hostname (ubuntu-tweak.com)

I have tried reinstalling everything other than the Software Center. The problem appeared a few weeks ago. My internet works fine. I ave screenshots of the errors but I don't think it would help much; they just look like an unstyled firefox Server Not Found error, and have a 'try again button'.

I have no clue what is wrong, and any help would be greatly appreciated!
Ubun2

share|improve this question

1 Answer 1

I have run into this issue a few times, when clicking the buy button it should take you to the Ubuntu login page and ask you to log in with your credentials.

After you have successfully logged in it should redirect you back to the store page and proceed with downloading the app.

Sometimes I have run into the error you have mentioned specifically with Steam. This seems to be linked to a bug regarding host name not being resolved correctly in Ubuntu 12.10.

Disconnect and reconnect to your router and try downloading again, This seems to be the only temp fix.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.