Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First of all I have to say I am using Ubuntu and Linux at all for a day now... so sorry if I ask dumb questions.

The problem is that I cannot find a way to get a wireless connection. In All Settings > Network I see only Wired and Network proxy, so I guess Ubuntu does not recognize any wireless card or at least does not have the right drivers to use it properly.

My PC is a HP Compaq Presario C500. Here is some information from the terminal:

lshw -class network:

  *-network UNCLAIMED     
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:80400000-80403fff


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


06:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

rfkill list all:

0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
share|improve this question

closed as off-topic by Braiam, Avinash Raj, Eric Carvalho, mikewhatever, BuZZ-dEE Feb 7 '14 at 9:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, Avinash Raj, Eric Carvalho, mikewhatever, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.

You're almost there. You've identified your WiFi adapter. It's a very common Broadcom BCM4311 device, which is not supported very well. Search for BCM4311 and you'll find tons of ways to get it working. Have you tried the application "Hardware Drivers"? It should suggest the installation of the driver. – gertvdijk Dec 23 '12 at 20:35
The "Additional Drivers" program has been moved to "Software Sources" found under the edit menu of the Software Center. – Seth Dec 23 '12 at 20:48
bcm4311 can be found in the "Additional Drivers" and "it is using alternative driver", but, nope... still nothing appears under wireless netowrks in Edit Connections... – user116415 Dec 23 '12 at 21:10
No reproducible – Braiam Feb 5 '14 at 12:50

first uninstall bcmwl-kernel-source and then make sure firmware-b43-installer and b43-fwcutter are installed

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer b43-fwcutter

share|improve this answer
I tried it several times, tried some other things I found here searching for solution... Unfortunately no luck... I guess I will go back to the old Windows and just wait for a working driver here. Thanks for the help, guys! Keep doing what u r doing! :) – user116415 Dec 24 '12 at 8:38

After doing this:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer b43-fwcutter
  • Then Reboot
  • And you need to activate the card from settings/network/wireless make it ON
  • After this search for wireless icon at the task bar and look for your wifi.

happy surfing :)

share|improve this answer
Welcome to Ask Ubuntu Ubee! There's already another answer that mentions the same steps. So instead of posting the same answer again, you can up-vote it by clicking on the little up arrow to the left of the answer. Invest some time in the site and you will gain sufficient privileges to upvote answers. If you think an answer can be a little bit improved, you can suggest an edit to it by clicking the edit link right underneath the text of the answer. Thanks! – Alaa Ali Sep 21 '13 at 7:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.