Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a wireless problem with this wifi adapter. At first when installing my Ubuntu 12.10 the STA driver was working fine. Then my wired connection wasn't working. After installing the alx driver and modprobing it the wire started working flawlessly. Then my wireless failed. There wasn't anything about wireless in the network manager. I've already looked and did what is said here, here. I removed the bcmwl-kernel-source package and installed firmware-b43-installer and b43-fwcutter. I've added the b43 driver in /etc/modules.

Then my wireless started working again for a while (1-2 minutes of browsing) and then disconnected. The only wireless network my laptop finds is my own wireless network (the router is next to my PC). There are a number of other networks in my building that don't show. After a reboot, the wireless 'decided' not to work again - int the network manager it's only stated : "Wireless Networks disconnected". So now I have only wired connection.

There is the output of some commands related to the issue:

lspci -vvnn | grep 14e4:

03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
Subsystem: Broadcom Corporation Device [14e4:0587]

iwconfig:

eth1      no wireless extensions.
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=19 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off

rfkill list all:

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy1: Wireless LAN
Soft blocked: no
Hard blocked: no

lsmod:

Module                  Size  Used by
nfnetlink_log          17845  0 
nfnetlink              14327  1 nfnetlink_log
snd_hda_codec_hdmi     32007  1 
snd_hda_codec_conexant    57842  1 
parport_pc             32688  0 
ppdev                  17073  0 
rfcomm                 42651  0 
bnep                   18140  2 
bluetooth             204950  10 rfcomm,bnep
arc4                   12529  2 
coretemp               13400  0 
kvm                   414070  0 
ghash_clmulni_intel    13180  0 
aesni_intel            51037  0 
cryptd                 20403  2 ghash_clmulni_intel,aesni_intel
aes_x86_64             17208  1 aesni_intel
brcmsmac              531127  0 
brcmutil               14755  1 brcmsmac
cordic                 12535  1 brcmsmac
snd_hda_intel          33491  3 
snd_hda_codec         134212  3        snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm                96580  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
b43                   370289  0 
mac80211              549340  2 brcmsmac,b43
cfg80211              211133  3 brcmsmac,b43,mac80211
snd_seq_midi           13324  0 
snd_rawmidi            30512  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61521  2 snd_seq_midi,snd_seq_midi_event
ideapad_laptop         18086  0 
sparse_keymap          13890  1 ideapad_laptop
snd_timer              29425  2 snd_pcm,snd_seq
snd_seq_device         14497  3 snd_seq_midi,snd_rawmidi,snd_seq
nouveau               895609  0 
psmouse                95552  0 
uvcvideo               76749  0 
serio_raw              13215  0 
videobuf2_core         32851  1 uvcvideo
videodev              120309  2 uvcvideo,videobuf2_core
videobuf2_vmalloc      12860  1 uvcvideo
joydev                 17457  0 
videobuf2_memops       13368  1 videobuf2_vmalloc  
ttm                    83595  1 nouveau
lpc_ich                17061  0 
mac_hid                13205  0 
i915                  520539  3 
snd                    78734  16     snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,s    nd_rawmidi,snd_seq,snd_timer,snd_seq_device
alx                    81256  0 
mxm_wmi                12979  1 nouveau
wmi                    19070  2 nouveau,mxm_wmi
bcma                   40069  2 brcmsmac,b43
ssb                    61895  1 b43
soundcore              15047  1 snd
snd_page_alloc         18484  2 snd_hda_intel,snd_pcm
pcmcia                 48964  2 b43,ssb
pcmcia_core            22569  1 pcmcia
compat                 14949  10    rfcomm,bnep,bluetooth,brcmsmac,b43,mac80211,cfg80211,alx,bcma,ssb
mei                    40690  0 
drm_kms_helper         49112  2 nouveau,i915
rts5139               356158  0 
microcode              22803  0 
drm                   288670  6 nouveau,ttm,i915,drm_kms_helper
lp                     17759  0 
parport                46345  3 parport_pc,ppdev,lp
i2c_algo_bit           13413  2 nouveau,i915
video                  19335  2 nouveau,i915
hid_generic            12493  0 
usbhid                 46947  0 
hid                   100366  2 hid_generic,usbhid

Can someone give any ideas on how I can fix my wireless to run smoothly?

share|improve this question

2 Answers 2

I was seeing the same error message on modprobe wl as Dimitar, on an Ideapad with bcm4314.

# dmesg | tail -2
[ 2795.255929] wl: disagrees about version of symbol lib80211_get_crypto_ops
[ 2795.255938] wl: Unknown symbol lib80211_get_crypto_ops

This led me to this bug report, where removing the linux-backports-modules was suggested.

# apt-get remove linux-backports-modules-*
# apt-get install --reinstall bcmwl-kernel-source
# reboot

made wifi work again.

share|improve this answer

Ok, so after a while digging I found out some stuff. I decided to reinstall my Ubuntu 12.10 (completely erased the previous one so everything is 'clean') and to try to work with the bcmwl driver. On the install page everything is fine - the wl driver (bcmwl-kernel-source) was working fine. After doing apt-get update my linux version updated from 3.5.0-17 to 3.5.0-21 . Then after reboot the wl module does not get loaded. When I issue the modprobe wl command I get a message that the module is not found. After following a forum suggestion I created a symlink in /lib/modules/3.5.0-21-generic/ to the file wl.ko located in /lib/modules/3.5.0-17-generic/updates/dkms/. After running depmod -a and modprobe wl I get:

FATAL: Error iserting wl (/lib/modules/3.5.0-21-generic/wl.ko): Invalid argument
FATAL: Error running install command for wl

dmesg says: this

So there is some mismatch with symbols. As I read here I think that after updating there isn't a new wl version for 3.5.0-21 and the kernel won't load the old wl as it sees that it is for an older version of the kernel. Am I correct in this statement ? And what is the support of this driver (I know that it isn't managed by the ubuntu community) but is it always behind updates ? (not to mention that my wired connection doesn't work with it at all).

share|improve this answer
    
Problem (I really hope in longterm) solved: I installed the latest .deb file from packages.ubuntu.com/quantal/bcmwl-kernel-source and everything is fine. I think that I had the 32 bit version of the driver, and I installed amd64 version (along with the other linux-header dependencies) –  Dimitar Vlahovski Dec 25 '12 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.