Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is a variation on what I asked in an earlier post that did not work for me or I did not quite understand the response. I have done a little more investigation so I hope I can ask a more suitable Question.

Let me start with at the beginning. I had a Freenas server that was humming away nicely until the system disk failed. There was no upgrade path to the latest version of Freenas so I decided to rebuild the server using Ubuntu desktop (I am a GUI guy). I booted from an Ubuntu live CD to recover my media from the UFS file system of Freenas. I copied that data to an NTFS disk (I wanted to be able to put it on a windows box if required). I the installed Ubuntu 12.04 to a USB. All good. I managed to Share the media etc No problems. I set up crashplan but the backups kept failing with out of disk space errors so I assumed (maybe incorrectly that temporary files were filling up my USB. The USB somehow go messed up so I started from installing Ububtu 12.10 to a new system HDD.

The NTFS drive (/dev/sdb) is connected and mounts at media/ron/...

For some reason the drive is mounted twice one with owner root and the other with owner me. Doing ls -1 I get this

ron@NAS:/media/ron$ ls -l total 16

drwx------ 2 root root 4096 Dec 19 19:51 wd2tb_bottom

drwx------ 1 ron ron 12288 Dec 23 19:23 wd2tb_bottom1

I can't get into the first due to permission (when I use sudo to get in there appears to be nothing)

My media appears to be fine in the 2nd mount.

Using the default ubuntu gui file manager to set share permission I ticked

Share this folder

Allow others to create and delete files in this folder

Guest access(for people without a user account

The folder Icon now has arrows indicating I assume that it worked.

Looking at the permissions however show

Owner:ron - Ron

Folder access: Create and delete files

File access: -

Group: Ron

Folder access:None

File Access: None

Others

Folder access:None

File access: -

If I change these and save nothing appears to happen and when I open the permission window again they are reset to above.

It is like it silently fails

When I share these folders they appear on a windows machine but I cannot open the folder windows tells me you don't have permission.

If I share a folder in my home drive I can see and access it from windows. Video I copy from my media drive to this shared folder can be seen from windows but cannot be opened until I change the permission of others. I don't really want to do this everytime I add a file to the folder

I tried to follow the instructions in post

I added the following to the

//NAS/media /media/ron/wd2tb_bottom1/Share cifs guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0

The instructions don't really explain what the "servername/sharename" should be

When I ran sudo mount -a I got this error

mount: wrong fs type, bad option, bad superblock on //NAS/media, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount. helper program) In some cases useful info is found in syslog - try dmesg | tail or so

In summary I want to

Share the drive I have but I cannot seem to successfully change the properties. Any assistance will be

Sorry for the long post but I have been trying to sort this out for several weeks now.

Thanks for you assistance.

share|improve this question
    
Crashplan has major problems running on Ubuntu, see here or here for examples. Use Ubuntu One or Dropbox instead. Costs more, but you get what you pay for. –  Tom Brossman Dec 23 '12 at 10:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.