Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed TF2 and when I launch the game, it gives me a black screen but sound however still works. It will not even display the Valve intro unfortunately. Any ideas on how coul i solve this?

share|improve this question
Valve problem. Recently, it released a patch for it, see if it works now. – LukeTheRuler Oct 31 '14 at 16:29

Welcome to the forums! Here are some commands that I found others have said have worked for them:

  • In terminal, run export LANG=C; steam


  1. In terminal, run export LC_NUMERIC=C
  2. Start Steam

You might also want to check out your drivers - try changing to other drivers (Settings Manager -> Software Sources -> Additional Drivers), and see if that works. If you change to a different driver, and it doesn't work, I would try running either of the above commands before switching to a different driver again.

Probably the best place to post bug reports and get support for anything related to Steam for Linux is at Valve's Steam-for-Linux Github. Not trying to shove you off the Askubuntu forums, just suggesting a better place for this specific issue.

Sources: Issue Report: Black screen on TF2 startup

Issue Report: Shader generation/compilation fails in TF2 - temporary fix - proper fix WIP

share|improve this answer
thanks, but i'm kind of a noob on ubuntu xd, do i have tu run the commands directly like this? inescarate@Hal-9000:~$ export LC_NUMERIC=C or do i have to put something before? – Scipio Dec 23 '12 at 16:11
You should be able to run them just like that. – DaimyoKirby Dec 24 '12 at 16:51
  1. s3tc texture compression

    Either do export force_s3tc_enable=true before running steam or add force_s3tc_enable=true right under the #!/bin/bash in /usr/bin/steam.

  2. Locale issues

    Either do export LANG=C and export LC_NUMERIC=POSIX before running steam or add LANG=C and LC_NUMERIC=POSIX under the #!/bin/bash in /usr/bin/steam. Apparently this has been fixed. Follow these steps:

    • Open a terminal and run:

      sudo nano /usr/bin/steam
    • Add the following lines after #! /bin/bash:

      export LANG=C
      export LC_NUMERIC=POSIX
    • Save (CTRL + O >> Then Enter >> Then CTRL + X)

    • Launch Steam

  3. No symlinks

    There must be no symlinks involved in getting to the SteamApps directory, or tf2 will fail on startup. If you don't want/don't have the space for tf2 in your home directory, just add /opt/Steam as another steam library or the sole steam library.

  4. Tell tf2 not to use a joystick

    Add -nojoy to the launch options for tf2.

  5. SELinux prevents tf2 from starting

    Run sudo setsebool -P allow_execheap 1 in the terminal to fix this.

  6. Windowed mode

    Add -window, -sw, -startwindowed or -windowed to the launch options.

  7. Proprietary drivers

    Some people have had luck installing the drivers from ATI's website. Be warned though that this often causes a plethora of other issues.


share|improve this answer
sudo -i

(enter root password)

apt-get update   
apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon    
apt-get install xserver-xorg-video-ati    
apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core    
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup    
rm -rf /etc/ati    
apt-get autoremove steam    
apt-get install steam

(agree to user agreement)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.