Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm really struggling to set up Debugging from my android phone with my 12.04 installation. For that matter, I'm struggling to set up pretty much any communication between the two aside from opening rhythm box when I connect via usb. For now, however, I'll be happy to get the debugging working. Here's what I have so far...

I'm using a Samsung Note 2 running Android 4.1.1. I am able to get into Debugging mode on the phone, so that's not the issue. The app has debugging enabled, so that's not the issue. I have set up the /etc/udev/51-android.rules file, and set the permissions. When I connect the phone via usb the phone does show up in adb devices, so everything should be working. However, when I click Select App to Debug on the phone the only option I get is "NOTHING". The only issue I can come up with is that it is somehow related to Ubuntu seeing the phone as a media device. I've done some research but have found no way of changing this.

share|improve this question
    
Where are you clicking "Select App to Debug"? I mean, usually you just set a breakpoint in Eclipse, click on the Debug button (again, in Eclipse) and it deploys and launches the app, stopping it when it reaches the breakpoint. –  Sergey Dec 23 '12 at 4:45
add comment

1 Answer

This may sound trivial but it solved my problem, try a different USB cable, it appears that there are USB cables for charging only not data and charging. I tried a cheapie cable I had picked up on sale and everything worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.