Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using an HP Officejet 6500 All-in-One for a few years now without any trouble. It is connected wirelessly to my network, for both printing & scanning. However, this week, scanning quit working, apparently as a result of some updates. After trying various things I found that it works fine connected using USB, but that's not a satisfactory fix.

I updated hplip to version 3.12.11 and tried reverting to the previous kernel version. Also, I've tried various scanner programs with varying failure messages such as the following hp-scan results:

3.5.0-20-generic x86-64 fails with:

Opening connection to device...
error: SANE: Invalid argument (code=4)

3.5.0-21-generic x86-64 fails with:

Expecting to read 10.9 MB from scanner.
Reading data: [|                                          ] 0%  0 B   
error: No data read.
Closing device.

Any suggestions are welcome.

Just realized that I should have made clear that printing still works well, via either wireless or USB.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

After many hours of googling & trying different suggestions, I gave up troubleshooting & uninstalled everything I could find to do with printers & scanners. Reinstalling seems to have cured the problem.

share|improve this answer
add comment

You have tried several remedies to no avail and I cannot swear that your problem is exactly what I experienced. However I am using MInt13 64 bit, which is based on Ubuntu 12.04. My printer/scanner is HP OfficeJet all-in-one 4620. I downloaded and installed hplip 3.12.11 and the scanner doesn't work. It is not even detected. However I have solved the problem like this:

Getting scanner to work with Mint13 Mate 64bit:

1) If necessary use a text editor as root to add 'hpaio' into '/etc/sane.d/dll.conf', that is if 'hpaio' doesn't appear already.

2) Use a File Manager (Nautilus perhaps), to go to /usr/lib and /usr/lib64, both as administrator/root.

In lib64, make link of directory 'sane', and then cut and paste it into directory /usr/lib; rename the created link as 'sane'. (N.B. There is probably already an empty directory 'sane' in /usr/lib which will first have to deleted or renamed in some meaningless way such as 'sane.original.empty').

This worked ok for me on 08/08/12. Now scanner works fine, either simplescan or xsane. This is a slightly edited version of my post on the Linux Mint forum dated 09 December 2012. I'm glad to say that someone has reported that it also worked for them!

share|improve this answer
    
Thanks for your suggestion, but hpaio already appears in /etc/sane.d/dll.conf & there is no /usr/lib64 on my system. ls -all /usr/lib/sane shows -rwxr-xr-x 1 root root 1066 Dec 22 13:21 libsane-hpaio.la lrwxrwxrwx 1 root root 22 Dec 22 13:21 libsane-hpaio.so -> libsane-hpaio.so.1.0.0 lrwxrwxrwx 1 root root 22 Oct 11 20:05 libsane-hpaio.so.1 -> libsane-hpaio.so.1.0.0 -rw-r--r-- 1 root root 150160 Oct 11 20:05 libsane-hpaio.so.1.0.0 –  davstev Dec 27 '12 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.