Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I recently upgraded my computer to Ubuntu 12.04 from 10.04 and it started messing up, as in, freezing up on certain programs and then randomly logging out and going to the log-in screen. I've done all of the upgrades and it still wasn't working properly.

Now when I turn the computer on, instead of booting to the GUI Interface, it boots straight to the terminal. Is there any command I can type to boot it properly? And if so, what do I do to keep it booting properly?

I did some research and found that some people used the "startx" command, but it didn't work for me. This is what it said:

"X: user not authorized to run the X server, aborting.
X10: fatal 10 error 11 (Resource temporarily unavailable) on X server ":0" after 7 requests (7 known processed) with 0 events remaining."

Any help would be greatly appreciated!

share|improve this question

marked as duplicate by Lucio, BuZZ-dEE, Alvar, blade19899, Seth Jan 3 '14 at 18:51

This question was marked as an exact duplicate of an existing question.

What does sudo startx give you? – Melon Dec 22 '12 at 20:20
@Melon sudo startx gives me: "Fatal server error: Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. Please consult the The X.Org Foundation support at for help. ddxSigGiveUp: Closing log "X: user not authorized to run the X server, aborting. XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0" after 7 requests (7 known processed) with 0 events remaining." – Aubrey Dec 22 '12 at 22:17
Can you show us the contents of /var/log/Xorg.0.log – Melon Dec 23 '12 at 7:43
@Melon I tried, but it says "bash: /var/log/Xorg.0.log: permission denied" I was finally able to log in to the GUI Interface. I'm not exactly sure how I did it, I just fiddled around. One thing is weird, though. I'm only able to log in as guest, not as my actual name. I do have a password, but it keeps saying that it's incorrect. So, now I'm logged in as a guest and I am able to use the terminal. I just don't know where to go from here... – Aubrey Dec 24 '12 at 3:45
Well, you can show the contents of the file with sudo. Also, can you switch to root with sudo su ? – Melon Dec 24 '12 at 8:58

Once you are connected, write sudo init 5 in the terminal prompt.

share|improve this answer
I tried the "sudo init 5" in the terminal prompt, but because I'm only able to log in as guest, I'm denied permission to use any sudo commands. This is what it said when I entered it: "sudo: unable to change to sudoers gid: Operation not permitted sudo: setresuid() [0, 0, 0] -> [125, -1, -1]: Operation not permitted" – Aubrey Dec 26 '12 at 17:05
I really need to figure out a way to log back in to my regular account. It tells me my password is incorrect, but I know it's not. I even changed it through the root menu, but it still didn't work. Once I can figure out how to log into my regular account, then I should be able to use the sudo command. The problem is figuring out how to get in... – Aubrey Dec 26 '12 at 17:08
I found a fix! Thanks for trying to help me. – Aubrey Jan 1 '13 at 18:27
up vote 0 down vote accepted

Okay everybody, it's fixed! Here's what fixed it:

Thanks to everyone who helped!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.