Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm connecting (to the internet) over a wireless connection (as in, it's already connected), but there's no wlan0. Output produced by ifconfig:

eth0      Link encap:Ethernet  HWaddr 5c:ff:35:06:9c:b3  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 

eth1      Link encap:Ethernet  HWaddr 00:26:82:76:6d:ee  
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:82ff:fe76:6dee/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:245381 errors:0 dropped:0 overruns:0 frame:160579
          TX packets:274599 errors:16 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:193751818 (193.7 MB)  TX bytes:32692764 (32.6 MB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:409 errors:0 dropped:0 overruns:0 frame:0
          TX packets:409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:31117 (31.1 KB)  TX bytes:31117 (31.1 KB)

The connection I'm "using" is obviously eth1. Just wanted to fix it, as a great conky script doesn't work (wireless network link strength indicator)

ps. nm-applet does show my wireless network link strength without a hitch.

share|improve this question
1  
Do you use ndiswrapper? Does the /etc/iftab exist? –  Dayjay Jan 25 '11 at 10:12
    
Dayjay: No, I do not use ndiswrapper, and /etc/iftab does not exist on my system. –  aviraldg Jan 25 '11 at 10:34
1  
I think you have to edit the persistent-net.rules file then. Just follow the link chris posted. –  Dayjay Jan 25 '11 at 10:53
    
Dayjay: No, it looks like you need to get Conky (or whichever process accesses the information) to run as root for it to get the stuff. Works that way, but I'd rather not... –  aviraldg Jan 25 '11 at 11:14

3 Answers 3

You can always rename your interface name from eth1 to wlan0. Instructions here. But I think the cleaner solution would be to pass the interface name to the conky script (if that is possible). Or possibly to edit the conky script so it checks for eth1 and not wlan0.

I'm also not sure how nm-applet would react to the interface name change.

share|improve this answer
    
changing the interface name in conky (to eth1) does not fix the indicator –  aviraldg Jan 25 '11 at 10:32
    
I assume you also restarted conky to check? –  chris Jan 25 '11 at 10:45
    
Yeah, I did restart it. –  aviraldg Jan 25 '11 at 10:55
up vote 0 down vote accepted

I found the solution for my question on the internet. Apparently, to get Conky (or anything else for that matter) to work with the Broadcom drivers, you need to run the application as the super user. So, to fix the problem, you'd:

sudo conky -d

instead of

conky -d

Also, the eth1 / wlan0 problem is specific to Broadcom drivers (and is supposed to happen with them)

share|improve this answer

What you need to do is load up your conky script into a sext editor, and search and replace wlan0 for eth1. also look for other scripts that the main script calls and do the same as this is reasonable common with conky.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.