Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello
I've been using ubuntu for 2 years now. And every 1 or 2 days I had something to upgrade. But today it's been maybe 2 or 3 weeks since the system detected the last upgrade to do. I think something goes wrong with my Xubuntu.

What I did :
1/ in synaptic I chose the repositories : Main , universe
And I chose the "Main server" to download from.

2/ then in a terminal :

sudo apt-get update
sudo apt-get upgrade

and I always have 0 new package to install ... Do you have the same "trouble" ? It's very strange. Thanks for your help

share|improve this question
4  
What version of Ubuntu are you using? –  Tom Brossman Dec 22 '12 at 18:36

2 Answers 2

If the version you installed 2 years ago is not listed here (11.04 for example), it is no longer supported and you should update to a newer release of Ubuntu.

To find your version of Ubuntu, press Ctrl + Alt + T and type lsb_release -a then Enter

Source here, plus @Powerlord's comment below

share|improve this answer
1  
Do we know this for sure? –  Tom Brossman Dec 22 '12 at 18:35
    
@TomBrossman From the Ubuntu support page: "If your version of Ubuntu is not listed above, it is no longer supported and does not receive security or critical fixes." The versions listed as of 2012/12/22 are 8.04 LTS, 10.04 LTS, 11.10, 12.04 LTS, and 12.10. That's the latest 3 normal releases and latest 3 LTS releases (12.04 is both). –  Powerlord Dec 22 '12 at 20:38
    
@Powerlord The most recent version to lose support was 11.04, on 28 October. That's well past the '2-3 weeks' from OP's question. Because of that contradiction, it isn't safe to assume that this is the root cause. Either Robin's estimate is off by nearly 2 months, or something else is wrong. –  Tom Brossman Dec 22 '12 at 20:49

My version was 12.04 so still supported. Finally I had found the trouble:

In Synaptic → Settings → Repositories → Updates nothing was ticked. So I ticked "Important Security Updates" and "Recommended Updates". Then updates worked again normally. :)

But I really don't know why they were "un-ticked". This is quite strange.

share|improve this answer
    
It's good to know you got your problem solved. You can accept your own answer now and close the question. –  carnendil Feb 20 '13 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.