Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I compiled vim 7.3 on my ubuntu 10.04, and here is the configure option:

./configure --disable-selinux --enable-luainterp --enable-perlinterp --enable-rubyinterp --enable-cscope --enable-multibyte --enable-xim --enable-gui=gnome2 --enable-pythoninterp=yes --with-features=huge

vim starts up quickly in the console, while gvim does not respond to any keyboard or mouse action for about 3 or 4 seconds after the window appears. The file I asked gvim to open can show up very quickly though.

The only option in .gvimrc is set guioptions=-T.

and this problem does not appear in the gvim7.2 installed in aptitude repository

I analyzed using the --startuptime option, the time is relative short, so the delay does not caused in startuptime. Can it be a delay after startup somehow?

share|improve this question
1  
For troubleshooting, try opening it with gvim -N -u NONE from the command line, which will make it not load your .vimrc or other plugins, and see if it's better then. –  frabjous Jan 25 '11 at 17:42
add comment

1 Answer

I think the reason is that gvim has to load more libraries than vim. If you're using a gnome environment, some of them - but maybe not all of them - are already loaded. gvim needs to load a vim session and then wrap it too.

Then again, it could depend on your .vimrc (even though you say vim loads fast).

One workaround could be having one and only one instance of gvim running and doing something suggested here, namely

alias gvim="gvim --remote-tab-silent"

which will open all new files in the same instance as a new buffer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.