Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a very nearly fresh Gnome version of 12.10, with no particular tweaks or customisation. I performed an upgrade yesterday using

sudo apt-get update; sudo apt-get upgrade

which completed successfully. After rebooting, I find that I am no longer able to log in - entering my (correct) password brings up a black terminal for a couple of seconds as usual and then returns me to the login screen. So far:

  • The guest account can log in fine
  • I can log in to a terminal via Ctrl+Alt+1 etc
  • Deleting all my gnome profile entries (.gnome, .gnome2, .gconf, etc) does not help
  • A new empty user (created using $ sudo adduser newguy; sudo passwd newguy) has the same problem
  • /var/log/syslog has some odd messages including

    gdm-simple-slave[1219]: WARNING: Child process -1838 was already dead

    WARNING: Failed to give slave programs access to the display. Trying to proceed

  • I installed kde-standard and had the same problem, so it is not a Gnome issue
  • Running startx from the terminal available through Ctrl+Alt+1 brings me to a working desktop. If this is allowed to go to screen-saver or is locked, I am unable to wake it (I get an "Authentication Error" message below the password entry field).
  • Opening a terminal in a guest session, running su - myusername and entering my password and gives the error setgid: Operation not permitted

I surmise that something about the Ubuntu login is broken, at least on my system.

Any suggestions will be most gratefully received...

share|improve this question

I've just solved this problem for me. It turned out there was probably a problem with certain permissions on my home dir. I remembered changing the permissions on my home dir. Because I have an encrypted home dir I couldn't change permissions on individual files, so I did the following.

alt f2 to get a tty

Login using normal credentials

sudo chmod 755 /home

That solved the problem for me. Now I just have to look for some sane homedir permissions.

EDIT: Taking it somewhat easier on the permissions

share|improve this answer
... and to revert that dangerous command for /home, use: sudo chmod 755 /home. – Lekensteyn Jan 29 '13 at 23:11
(removed previous comment) What makes you think that a chmod 755 on /home will change? It's in this mode by default on Ubuntu. – gertvdijk Jan 29 '13 at 23:42
I had been messing with my permissions because of an other issue. – BakaKuna Jan 30 '13 at 8:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.