Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm not sure if anyone has the same problem. It can be a problem of my own system, as I didn't find any signs of it in Google, that's why I'm not sure if it's worth a bug report.

Preconditions: Pidgin is added into tray whitelist; showing mode "Always" in enabled for tray icon. I'm running Ubuntu 12.10 with Unity, Pidgin v.2.10.6.

My actions: 1) Verify that Pidgin icon is visible in tray. 2) Open a full-screen application (in my case, those were Wine or SMplayer) 3) Switch back to any non-full-screen app using Alt-Tab.

And the Pidgin icon disappears from the tray. To enable it again, I switch 'Show icon in tray' property to any other mode, and then back to 'Always'. Can anyone reproduce this problem? What configuration files and/or logs should I look into?

Thank you!

share|improve this question
    
This seems to be the same problem as bug 932769 on Launchpad. The interesting thing is that you can get your icon back, which might provide a hint at the cause of this problem. –  user127094 Jan 29 '13 at 19:02
add comment

2 Answers 2

I have the same problem too, but if you activate panel transparency (actually opacity) from CCSM, you will see your icon in background.

I got it with VirtualBox and Teamspeak3 icon in tray.

I have added a screenshot so developers can fix it. It does not just gone, just stays behind the menu bar! Sys-tray App icon bug

share|improve this answer
add comment

I do have the same problem here and I can confirm that the Pidgin icon always disappears after using Alt-Tab in fullscreen mode.

Version Information:

  • Ubuntu 13.04
  • Pidgin 2.10.7
  • Gnome 3.6.2

But I can not enable it again by switching the 'Show icon in tray' property in Pidgin to any other mode, and then back to 'Always'.

Also I can not confirm that the icon will be visible behind the panel when opacity is lowered. (By the way, the Opacity setting has moved from the "Experimental" tab to "General" in the Ubuntu Unity Plugin.)

It only does appear again with the command "gnome --replace" or after logging off and on.

Help on this topic is still appreciated!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.