Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install BSNL EVDO Rev A USB Data Card Model No.:T-U500 on my laptop which is double booted with both ubuntu and windows 7. BSNL evdo works well on windows 7 and I tried to install it on ubuntu.

I don't have internet connection in Ubuntu.

I tried to install using terminal

at@at-Presario-V3700-Notebook-PC:~$ sudo modprobe usbserial vendor=0x15eb product=0x7153
at@at-Presario-V3700-Notebook-PC:~$ sudo wvdialconf

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.
Modem Port Scan<*1>: S0   S1   S2   S3   S4   S5   S6   S7   
ttyUSB0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?
Please read the FAQ at

TWO: Then I tried to follow

And after I typed wvdial I am getting error /etc/wvdial.conf I edited to:

[Dialer Defaults]
Dial Command = ATDT
Dial Command = ATDT
Flow Control= Hardware (CRTSCTS)
Username = 9180326472
Password = 9180326472
Phone = #777
Stupid Mode = 1

resolv.conf I edited to

hash Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

(By hash I mean #)

What I typed in terminal:

root@at-Presario-V3700-Notebook-PC:~# vim /etc/wvdial.conf root@at-Presario-V3700-Notebook-PC:~# vim /etc/resolv.conf root@at-Presario-V3700-Notebook-PC:~# wvdial --> WvDial: Internet dialer version 1.61 --> Cannot get information for serial port. --> Initializing modem. --> Sending: ATZ --> Sending: ATQ0 --> Re-Sending: ATZ --> Modem not responding. root@at-Presario-V3700-Notebook-PC:~#

After doing all this I logged into Windows, uninstalled it, unplugged the modem, plugged it again, clicked "open folder to view files", clicked Linux, Copied "BSNL EVDO Installer" to the desktop. Then I logged onto Ubuntu moved the file into its desktop and installed it. After installation I clicked "EVDO Data Card" but nothing happened. What should I do? Is the problem caused by something I did above?

share|improve this question

You need to install two software packages to make the internet connectivity work consistently without breaking. They are wvdial and gnome-ppp (The front-end tool to configure wvdial).

1) Install wvdial package

Open terminal,(alt+ctrl+t) and type the following command

sudo apt-get install wvdial

2) Install gnome-ppp

sudo apt-get install gnome-ppp

3) Open gnome-ppp from the terminal.

sudo gnome-ppp

4)You have to enter your BSNL 10-digit mobile number in the Username & your password. Type *99# in the number row. Then press the Setup button below.

5) In the Setup window below, click the “Detect” button to identify the device ID of the USB port in which you have inserted your USB modem. The tool would automatically detect the Device, Type and Speed of your USB modem. Once it has deteced, please the “Close” button below.

Once this is done click on Connect!!!

You could also configure it through the terminal. This link should help you to configure it via terminal.

You could also try installing can get it here

share|improve this answer
whats the error you get? – Mukund Dec 26 '12 at 8:54
No modem was found on your system – chndn Dec 26 '12 at 9:15
Do you have any other Operating system in your hard disk other than Ubuntu? – Mukund Dec 26 '12 at 9:25
Yes WINDOWS 7 is also there – chndn Dec 26 '12 at 9:27
ok cool!now log into win7 first and insert the modem/dongle. Restart the computer and then log into ubuntu. but keep in mind that dont disconnect or eject the modem from pc and dont switch off the main power. Doing so You have to do the process again. – Mukund Dec 26 '12 at 9:29

Did you enable Mobile Broadband in the network menu? Once you enable it, a wizard will pop up to add your dongle. Choose India and then BSNL and choose your appropriate plan. I followed the same procedure for my Reliance 3G dongle. No need for the terminal at least in my case. Ubuntu installed all the relevant packages automatically.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.