Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use an hdmi cable to connect my HP dv5 notebook to a 32" Sony Bravia tv in order to watch Hulu stuff on a bigger screen. However, Google has been thoroughly unhelpful thus far!

When I hook the computer up to the tv using the Windows partition, it automatically switches the display settings so that the sound and video on the tv are synced up with what's on the laptop screen. In the Ubuntu partition,I think that it's detecting the tv as another monitor rather than as a tv, so I get a dual monitor display, which I don't want! Plus, the sound is coming out of the laptop rather than out of the tv.

I don't know if the laptop's intel driver is enabled for tv in the Ubuntu partition (I don't think it's an nvidia driver, but I don't know how to check it), and I don't know how to manually change the settings to optimize tv display.

EDIT: I think this is the relevant information from the lspci command:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Doesn't seem like I have an nvidia chip. I figured that I didn't, since the terminal didn't recognize commands pertaining to it. My ultimate goal is to mirror the laptop output on the tv screen-- is this doable?

share|improve this question
    
Use lspci to check whether you have an nvidia chip or not, to set the audio for the HDMI manually change the output from the Sound settings from the Laptop speakers (Analog stereo) to the HDMI output. –  Uri Herrera Dec 22 '12 at 8:48
add comment

5 Answers

I have an Asus Zenbook Prime with an Intel HD integrated GPU. My machine has the same issues with video and sound settings not automatically switching when I plug in a TV over HDMI.

To resolve the video I can either press the external monitor hotkey (FN+F8) to cycle between Laptop only, TV only, Mirrored, and Extended desktop modes. Your laptop may not have this function button so you can also launch the Displays control panel either directly or from the System Settings application. This should identify both of your displays, which you can turn on and off independently or check the Enable Mirroring box to simply mirror you laptop display.

Sound over HDMI can be tricky. An HDMI output device may appear in the Sound control panel in System Settings, but on my machine this doesn't happen. To resolve this, I use PulseAudio Volume Control. You can find this by searching for it in the Ubuntu Software Center. To use it, launch the app and click on the Configuration Tab. There should be a drop-down menu for your sound card labeled Profile, select Digitl Stereo(HDMI) Output from this menu.

Once this is done, the Sound control panel should show both the built-in speakers and the HDMI output and you should be able to switch between them as often as you want from there while you are plugged in to the HDMI output. On my laptop it also doesn't automatically switch back to the speakers, you may need to manually select them in the Sound control panel to go back to analog sound output.

share|improve this answer
add comment

I had the same problem, mine's was result by opening the dash and write it down: sound, open it and in output tab, appear HDDMI / Display Port I select it and wuala it works for me. My computer is a Asus k52f. I hope this solve your problem. ! [Sound] Click on Sound THEN... it appears enter image description here Click on HDDMI / Display Port and the tv sound should work fine, I saw The dark night rises yesterday using HDMI port!

share|improve this answer
add comment

I'm not 100% on ubuntu just thought i'd try to answer your issue for you I do use windows but i'm guessing it can't be that much of a difference so i hope this helps or gives you some insight on how to try and fix it.

To stop it from doing dual monitor go into screen resolution and look for multiple displays click the menu and you will get a few options try show desktop only on one, if not try the other option and if not fiddle with it... after 10-15 seconds the display reverts back so don't panic if your screen goes black.

as for the sound, go click the speaker icon and look for sound click on that then look for playback ( this is once you have the screen sorted and the hdmi plugged in ) there should be a list and it should show your tv on there click it and set it as default device.

Again im just explaining as if you was to be using windows ... if it doesn't work i'm installing ubuntu now i'll take a look but hopefully you'll have your answer you're looking for by then.

Best of luck

share|improve this answer
add comment

The issue for me was that my laptop and the TV could not simultaneously have their screens on. I had to turn the laptop screen off in order to configure the resolution I wanted for the TV, otherwise I could only mirror my laptops' resolution onto the TV. Same story with using a projector.

For the sound, in sound settings you need to change the sound output from analog to HDMI Audio.

In windows, the option only pops up after you've connected via HDMI -- but in Ubuntu you can do so any time you wish, you just won't hear anything if you aren't connected to an alternate sound source through HDMI.

share|improve this answer
add comment

Ubuntu 12.04: SToggle – HDMI sound toggle/switch

Here You Go, It only works until reboot for me but it's better than nothing..

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Also, when linking to your own site or blog please mention that you own that particular site, otherwise your answer starts to look like spam. –  Seth Apr 3 '13 at 23:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.