Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need some help. During install first steps ubuntu installer stops during HDD detection.(just before he asks about install side by side with win). It is a 750gb seagate with UEFI system and win 7 64 bit, verified ubuntu MD5 and image is correct, trying to install from USB, but as I mentioned Live works fine and everything works can access HDD and partitions no problem. I just cant install as the installer hangs. I have been reading some articles but all mention boot issues and none mention the installer hanging. Anyone has any ideas?

share|improve this question
    
I also had trouble with past Ubuntu versions recognizing the hard disk. Try adding a boot flag of "pci=nomsi" and see if that helps. –  BryceAtNetwork23 Dec 21 '12 at 21:40
    
Thank you for your quick reply. However im new to ubunto dont really know how to add the flag to boot. Should i edit what file in the USB pen? –  Murias Dec 22 '12 at 4:00

2 Answers 2

Found a solution credits go to Rod Smith http://askubuntu.com/users/57976/rod-smith Thanks

Your parted output suggests you've got a partition table problem, or at least an issue that libparted (which is used both by the text-mode parted program and the Ubuntu partitioner) is interpreting as a partition table problem. The "Invalid or incomplete multibyte or wide character" message suggests that parted is having problems interpreting the partition name, which is officially a UTF16-encoded name. Unfortunately, the last time I checked, parted didn't do proper UTF-16 encoding or decoding of partition names; instead, it tried to interpret them as a sort of modified ASCII -- or in practice, a modified UTF-8. This could lead to problems if a real UTF-16 partition name used non-ASCII characters, since they might then look like gibberish when interpreted as a modified UTF-8. Since libparted is very sensitive to errors and offers little in the way of corrective tools, the result is an error, as both parted and the Ubuntu installer demonstrate.

If I'm right (and I'm far from certain that I am), you should be able to correct the problem as follows:

Boot into the Ubuntu (or any other Linux) rescue disk.
If necessary, download and install GPT fdisk (gdisk). It's available as the gdisk package in Ubuntu.
Type sudo gdisk /dev/sda to launch gdisk on your problem disk.
Type v to verify the disk's data structures. If gdisk reports any problems, it could be that parted was reacting to some problem other than the partition name, and that may need to be dealt with instead of (or at least before) proceeding with the below steps.
Type p to view your partition table. Look for any non-ASCII characters in the "Name" column.
Type c to change the name of any partition that has a strange name. You'll be asked for a partition number and a new name. Repeat this for as many partitions as necessary (up to all of them).
Type p to review your partition table to be sure everything looks sane.
If everything looks good, type w to save your changes and exit from gdisk.

If my suspicion is correct, you should now be able to proceed with Ubuntu installation. If I'm correct, this is a libparted bug, which should be reported to Ubuntu and/or to the libparted developers. Recording the names of all your partitions for inclusion in your bug report is worth doing.

share|improve this answer
    
Wow, good find! I'm glad you were able to figure that out. –  BryceAtNetwork23 Dec 31 '12 at 14:05

As mentioned in my comment, one thing I would try is to modify the boot parameters. I didn't have this problem with 12.04 or 12.10, but for prior versions of Ubuntu I had to add a boot parameter of "pci=nomsi" to get it to find my hard drive (essentially preventing device drivers from generating a Message Singaled Interrupt).

Here is an article that describes how to alter the boot parameters prior to installation. Basically, you'll need to get to the advanced boot menu. From there, pressing F6 (followed by esc to close the pop-up menu) should enable editing of the boot command. Go all the way to the end of the line and add pci=nomsi.

Try that and post back if it doesn't work. If it doesn't work another thing to try would be to remove dmraid prior to installation, as mentioned in this post: Ubuntu Install Failing- Hard Drive.

share|improve this answer
    
Hi its me again :-( i try the ´sudo apt-get remove dmraid´ solution that did not work. Im trying to find the option for F6 but it does not show on the screen. I look everywhere i only have a menu Grub that allows some options (live, install, check for errors) but I do not see the menu during live boot as described to press the F keys. –  Murias Dec 26 '12 at 0:23
    
I try ubuntu 10.04.1 and it almost works i get ubi-partman failed with exit code 141 –  Murias Dec 27 '12 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.