Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble getting my Wireless to work on Ubuntu 12.10. My laptop is a Dell 3520 and the wireless chipset is Broadcom BCM43142 pci.id [14e4:4365] rev 1.

The below question looks similar to my issue and I tried it but it didn't work:

Dell Inspiron 5720 Wifi (Broadcom BCM43142, Ubuntu 12.10)

When I try to sudo dpkg -i wire*.deb I get the below message:

Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed.

When I grep for my installed headers using dpkg --get-selections | grep headers I see that I have:

linux-headers-3.5.0-17
linux-headers-3.5.0-21
linux-headers-3.5.0-21-generic
linux-headers-generic

Any idea what the issue is?

I checked if the wireless-bcm43142-dkms package got installed and it looks like it is when I do: dpkg --get-selections | grep bcm.

share|improve this question
    
Welcome to Ask Ubuntu! You had previously indicated that this answer solved your problem. Assuming that is the case, you should accept that answer by clicking the green check mark to the left of it. That makes it clear to people searching with similar problems that this answer worked for you (and thus might work for them). It also shows that you are no longer seeking solutions to this problem, which is important because it means people answering question may apply their attention elsewhere to help others. –  Eliah Kagan Dec 23 '12 at 11:21

2 Answers 2

Please try:

sudo apt-get install --reinstall linux-headers-`uname -r`

Those backticks are on the left side of my US keyboard on the same key with ~. After the headers for your currently running kernel are reinstalled, try again:

sudo dpkg -i wire*.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.