Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed lubuntu-desktop on top of ubuntu 12.04. I understand that chromium is the default browser in lubuntu but I was expecting Firefox to show up under the Internet menu. It is installed in my computer, and it shows in the Lubuntu Software Center under installed applications but I cannot find it anywhere. How do I have it show up on the Internet menu?

share|improve this question
    
What do you see when you run locate firefox.desktop? Do you have such a file? It should normally be in /usr/share/applications and you should see the regular Firefox icon. If you do, right-click on it and view it with a plain text editor. Then edit your question here to include the relevant lines. (There'll be a lot of lines in other languages.) It's possible that there's some line such as TargetEnvironment=Unity that may prevent display in a "Lubuntu" session. But, as the answer below suggests, a purge/install may do the trick. –  user25656 Dec 22 '12 at 5:35
    
Yes I found the firefox icon there, and I can open it if I double click on it. How do I modify the text file so that it appears in the lubuntu menu? The last line of the text file reads OnlyShowIn=Unity;. –  user87317 Dec 22 '12 at 19:40
    
I have offered an answer below, but it would have helped if you provided the relevant lines of the .desktop file in your original question. If you are unsure of what to provide, just paste the full thing in your question within code tags and someone can later edit out the unnecessary lines (related to languages). –  user25656 Dec 23 '12 at 3:43

2 Answers 2

up vote 4 down vote accepted

Here's what you can do. While in a Lubuntu session:

  • Open two windows of your file manager side-by-side.
  • In one window, go to /usr/share/applications and make sure that the Firefox icon is visible.
  • In the other window, go to ~/.local/share/applications and make sure you have enabled viewing "hidden files and folders". (In case you do not have ~/.local/share/applications, just create such a folder.)
  • Now, copy the Firefox desktop file from /usr/share/applications to ~/.local/share/applications. (You should be able to do this without needing sudo.)
  • Right-click on the copied file (do not double-click, please).
  • Choose to open with a simple text editor (gedit or leafpad).
  • Find the line that says "OnlyShowIn=Unity;". Delete that line if that is the only content on that line or comment it out by placing a # at the beginning of that line. Else, carefully, delete just "OnlyShowIn=Unity;". Note that the "opposite" of OnlyShowIn=, is NotShowIn=. I understand that TargetEnvironment=, which would be synonymous to OnlyShowIn=, is now deprecated.
  • At this point, if you save and close the file and check in your Lubuntu menu, you should see Firefox listed.

To minimize confusion, you could do some more by further editing the desktop file in ~/.local/share/applications.

  • Search for all lines exactly beginning with Name=. (There could be more than one.)
  • Replace Firefox with L-Firefox or whatever.

After saving and closing the desktop file, you'll see whatever name you have provided appear in the menu (along with regular Firefox when you run Unity).

share|improve this answer
    
Thanks a lot. This worked. I did not change any lines beginning with Name=, I don't see what kind of confusion could potentially arise. If some confusion does come up I can go back and edit those lines. Thanks again. –  user87317 Dec 25 '12 at 18:30

Try purging and re-installing via terminal:

sudo apt-get purge firefox && sudo apt-get install firefox

Hopefully that will fix it.

I had some problems getting the lubuntu-desktop package to work, so if you want LXDE I would recommend just doing a clean install of Lubuntu or just installing LXDE.

Edit: Note that purging will not affect user-specific settings and important things like passwords, bookmarks, history, extensions, and such which are stored in your home folder, typically in ~/.mozilla. As a precaution, you could back up the folder which ends with the letters "default" and is present in ~/.mozilla/firefox.

share|improve this answer
    
Will purging it erase all my bookmarks and other settings? –  user87317 Dec 22 '12 at 19:22
    
I did not give this a try, but sounds like this would work if I don't lose personal settings. –  user87317 Dec 25 '12 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.