Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a portable USB hard drive that contains several encfs folders, which I manage using Cryptkeeper.

Yesterday I upgraded my desktop machine to Ubuntu 12.10, and today I find that Cryptkeeper longer recognizes the encfs folders on my portable drive, although it still recognizes the encfs folders on the desktop's internal hard drive.

The portable drive is apparently being mounted correctly when I plug it in. An icon appears on the unity bar, and the drive is browsable through Nautilus.

Clicking on the Cryptkeeper notification icon drops down a list of encfs folders, as it should. The encfs folders on the internal hard drive are bolded and can be opened as normal. The encfs folders on the portable drive are listed, but are greyed out.

I have tried:

  1. importing the encfs folders from the portable drive again. When this option is selected, I can navigate to the portable drive, but the encfs folders are not shown in the import selection window.

  2. Creating a new encfs folder on the portable drive. This worked normally; the new file was created, and the new folder shows up in bold on the Cryptkeeper and can be opened and closed normally.

A possibly related issue is that the unity icon for the portable drive no longer contains a "safely remove" option when right clicked..however, this may be a change with the upgrade to Ubuntu 12.10

Another possibly related issue is that when right clicking the unity icon for the portable drive, and selecting "unmount" there is some disk activity on the portable drive, but the unit icon does not disappear as you would expect, until the drive is physically unplugged from the machine.

Finally, the encfs folders on the portable drive function normally on my laptop, which is still running Ubuntu 12.04.1 LTS. The Cryptkeeper version on both machines is 0.9.5

Obviously, something has changed with the upgrade to 12.10. What can I do to restore the functionality of the encfs folders from the portable drive on the desktop machine? I am holding off upgrading the laptop until this functionality is restored.

Edit: Just noticed that the unity icon for the portable drive on the desktop, running 12.10 also does not show a "format" option when right clicked, as the unity icon does on the laptop running 12.04. Again, this may just be a difference between 12.10 and 12.04, or it may be related to the problem.

share|improve this question
    
thanks a lot ! It was great help, I recovered my folders. –  user139563 Mar 12 '13 at 1:21

1 Answer 1

Noticed that the mount points appeared to be different between the old portable drive encfs folders on the cryptkeeper display, and the new encfs folder I had created as a test.

The old folders were simply shown as /media/name-of-drive/name-of-folder whereas the new mount point for the test folder was media/username/name-of-drive/name-of-folder

I went through the import process again, this time using ctrl-h to make the .encfs folders visible in the directory (should have remembered that before!). Selecting one of the old encfs folders resulted in a new, valid entry in the Cryptkeeper dropdown, which worked fine.

Now I'm wondering why this changed between the two Ubuntu versions, but regardless, I have my functioning encfs folders back again.

share|improve this answer
    
Solution given by OP askubuntu.com/posts/231428/revisions –  Braiam Jan 3 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.