Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I use my external mouse with my laptop, I physically disable the touchpad by pressing a button. Ubuntu detects this switch correctly, and will display an overlay that shows the current state of the touchpad (enabled or disabled).

However, I do not enable it again before shutting down the system. When I reboot, the touchpad is physically enabled by default, but Ubuntu remembers it as disabled.

Ubuntu loads with the system thinking "touchpad disabled", so I cannot move the pointer. When I physically disable it, the system thinks it's enabled, but of course I cannot do anything with it either.

Is there a way to make the system forget the touchpad state on shutdown and then have it detect that properly on boot? I think this is strange and even idiotic behaviour, the system should not rely on some file on the hard disk to detect whether the touchpad is enabled. Persisting such state by default is useless in my opinion.

There are other people that had similar problems, but they used software. I use only the default system settings. I know that it is possible to make the state of the touchpad depend on the external mouse being plugged in or not, but my external mouse has a very small connector that is designed to stay plugged in at all times. Very handy as it doesn't get lost and I don't have to pull it out and push it in all the time.

share|improve this question
    
When I use an external mouse with my laptop, Ubuntu detects the external mouse and disables the touchpad on its own. When I unplug the mouse, the touchpad gets enabled. YMMV. –  user68186 Dec 21 '12 at 16:48
    
@user68186 I know that is possible, but my external mouse has a very small connector that is designed to stay plugged in at all times. Very handy as it doesn't get lost and I don't have to pull it out and push it in every time. –  MDeSchaepmeester Dec 21 '12 at 17:04
1  
Thanks for the clarification. You may want to add it to question above. One solution is to install Jupiter and use keyboard to navigate to its menu and enable the touchpad. I hope you find a better solution to the problem. –  user68186 Dec 21 '12 at 17:14
1  
@user68186 thank you, I did that just now. –  MDeSchaepmeester Dec 21 '12 at 17:16
1  
You are welcome. If you don't find any other solution, I will put my comments as an answer that you can then accept. –  user68186 Dec 21 '12 at 17:22
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.