Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed nvidia's cuda toolkit in ubuntu 12.04. After restarting the computer, it stays in console mode. When I run sudo service lightdm restart, it gets stuck mid execution and the computer remains in console mode after a forced reboot. What can be done here?

share|improve this question
Are you sure that you have an nVidia GPU which is CUDA capable? – Francesco Dec 21 '12 at 17:57
yes, the gpu is cuda capable. I solved the issue already. – andandandand Dec 21 '12 at 20:06
up vote 1 down vote accepted

I solved the issue by uninstalling the cuda driver (via an nvidia purge command) included in the sdk and using instead the one provided here.

sudo service lightdm restart worked fine then.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.