Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background

I'm running Ubuntu as a guest OS in a VM. Originally the VM was created with Ubuntu 9.10 64-bit and with vmware-tools installed, when I resized or maximized the VMware Player, the guest OS was correctly and automatically resized. Once I upgraded to Ubuntu 10.04 (not reinstalled), automatic resizing no longer works. However, the mouse and network drivers do continue to operate properly.

When installing vmware-tools in 10.04, I notice a lot of LSB warnings for upstart jobs that were not thrown when installing it in 9.10.

Environment

  • Distro: Ubuntu 10.04 64-bit
  • Kernel: Linux nitrogen 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 05:14:15 UTC 2010 x86_64 GNU/Linux
  • VMware Player: 3.0.1 build-227600
  • Host OS: Windows 7 Home 64-bit

What I've already tried:

  • Reinstalling vmware-tools
  • Updating to the latest patch level of VMware player 3.0.1
  • Updating all installed Ubuntu packages, including kernel (and then re-install vmware-tools)
  • Manually creating entries in xorg.conf for the host's fullscreen resolution

Problem

When I resize or maximize the VMware Player window, the guest OS size stays fixed.

Question

How do you configure vmware-tools for VMware Player 3.0.1 in Ubuntu 10.04 64-bit to enable automatic guest resizing?

Update

I don't know exactly WHY this fixed my issue, but on Aug 28th, 2010 a set of package updates came out that (see below), after installation, magically resolved this issue. I'm Guessing it has something to do with the xorg packages.

Start-Date: 2010-08-28  08:05:49
Install: ttf-dejavu-extra (2.30-2)
Upgrade: libsmbclient (3.4.7~dfsg-1ubuntu3, 3.4.7~dfsg-1ubuntu3.1), language-pack-gnome-en-base (10.04+20100422, 10.04+20100714), libkpathsea5 (2009-5ubuntu0.1, 2009-5ubuntu0.2), smbclient (3.4.7~dfsg-1ubuntu3, 3.4.7~dfsg-1ubuntu3.1), linux-image-2.6.32-24-generic (2.6.32-24.39, 2.6.32-24.41), ubufox (0.9~rc2-0ubuntu2, 0.9~rc2-0ubuntu2.1), language-pack-gnome-en (10.04+20100422, 10.04+20100714), xserver-xorg-core (1.7.6-2ubuntu7.2, 1.7.6-2ubuntu7.3), ghostscript-cups (8.71.dfsg.1-0ubuntu5.2, 8.71.dfsg.1-0ubuntu5.3), xserver-common (1.7.6-2ubuntu7.2, 1.7.6-2ubuntu7.3), libwbclient0 (3.4.7~dfsg-1ubuntu3, 3.4.7~dfsg-1ubuntu3.1), icedtea-6-jre-cacao (6b18-1.8-4ubuntu3, 6b18-1.8.1-0ubuntu1), linux-headers-2.6.32-24-generic (2.6.32-24.39, 2.6.32-24.41), openjdk-6-jre-lib (6b18-1.8-4ubuntu3, 6b18-1.8.1-0ubuntu1), libfreetype6 (2.3.11-1ubuntu2.1, 2.3.11-1ubuntu2.2), openjdk-6-jre-headless (6b18-1.8-4ubuntu3, 6b18-1.8.1-0ubuntu1), samba-common (3.4.7~dfsg-1ubuntu3, 3.4.7~dfsg-1ubuntu3.1), linux-headers-2.6.32-24 (2.6.32-24.39, 2.6.32-24.41), ifupdown (0.6.8ubuntu29, 0.6.8ubuntu29.1), tzdata-java (2010k-0ubuntu0.10.04, 2010l-0ubuntu0.10.04), libdjvulibre21 (3.5.22-1ubuntu4, 3.5.22-1ubuntu4.1), ghostscript-x (8.71.dfsg.1-0ubuntu5.2, 8.71.dfsg.1-0ubuntu5.3), libservlet2.5-java (6.0.24-2ubuntu1.2, 6.0.24-2ubuntu1.3), libgs8 (8.71.dfsg.1-0ubuntu5.2, 8.71.dfsg.1-0ubuntu5.3), tzdata (2010k-0ubuntu0.10.04, 2010l-0ubuntu0.10.04), ghostscript (8.71.dfsg.1-0ubuntu5.2, 8.71.dfsg.1-0ubuntu5.3), google-chrome-beta (6.0.472.33-r55501, 6.0.472.51-r57639), linux-libc-dev (2.6.32-24.39, 2.6.32-24.41), samba-common-bin (3.4.7~dfsg-1ubuntu3, 3.4.7~dfsg-1ubuntu3.1), upstart (0.6.5-6, 0.6.5-7), libdjvulibre-text (3.5.22-1ubuntu4, 3.5.22-1ubuntu4.1), language-pack-en-base (10.04+20100422, 10.04+20100714), binutils (2.20.1-3ubuntu6, 2.20.1-3ubuntu7), openjdk-6-jre (6b18-1.8-4ubuntu3, 6b18-1.8.1-0ubuntu1), language-pack-en (10.04+20100422, 10.04+20100714)

End-Date: 2010-08-28 08:09:25

share|improve this question

closed as too localized by Oli Oct 25 '11 at 11:25

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Are you running the vmware-tools that comes with vmware? Or openvm-tools? I'd try openvm-tools (you can get the package over apt) and see if that works better. You may want to fully uninstall vmware-tools first, and restart X (or just reboot) after openvm-tools is finished installing. –  Ken Simon Sep 2 '10 at 23:43
    
I experience a similar problem after installing updates. Re-installing the VMWare tools seems to fix it. –  Jon Aug 22 at 20:34

2 Answers 2

I don't know the solution to this problem, but I'm also running Ubuntu 10.04 as VMware guest and thought some observations might be helpful. I normally use VMware Workstation (7.1.0 build-261024), but I did load this VM with the Player to verify that it behaved in the same fashion.

My VM was originally a fresh install, rather than an upgrade. The resizing appears to be working as intended. I don't know if it's relevant but the Ubuntu guest doesn't have the feature where the mouse moves seamlessly between host and guest, but I don't think I've ever used that with an Ubuntu guest on VMware.

In the virtual machine settings on my machine, the display setting is set to "Use host settings for monitors".

You mentioned that you manually created some configuration in xorg.conf, but I notice that my VM doesn't have an xorg.conf file but does have a whole bunch of available modes in the display settings control panel. I think it may be worth investigating if something changed with the X server configuration in the upgrade that could be resolved by reinstalling it with the default settings.

share|improve this answer

i dont know about vmware, but with virtual box, they there is a setting that says adjust with windows size, which you can enable and you can run smooth. I believe porting your guest system in vmware to vbox is straightforward and simple. Link here plus its free, as well as creating guest OSes as well.

:)

share|improve this answer
    
Yeah, the issue is that it won't resize at all, neither automatically nor when I explictly instruct it to "Fit Guest". The issues for me using Virtual Box are that A) I'm much more familiar with VMware since I use it at work all the time B) Some Windows OSes that I use work better in VMware C) I have to get the closed-source version of VirtualBox for the features I need anyways –  Burly Aug 16 '10 at 11:07
    
The "closed" package of VirtualBox is still free for "Personal" use - the definition of personal is fairly liberal (see paragraph 6 of their [licensing FAQ] [1] ) - as long as you are acting as a single user and don't start distributing it centrally you are covered. You are apparently comfy with VMWare so I don't think you are bothered on ideological grounds :-) [1] virtualbox.org/wiki/Licensing_FAQ –  Adrian Aug 25 '10 at 15:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.