Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a new user to Ubuntu and I have a problem:

I had Windows XP in my computer and I had two partitions: C (for system data) and D(for my personal stuff), then, during the Ubuntu installation I chose the Advanced Settings and formated C partition and left D partition intact, went back and chose Install Ubuntu and replace Windows and it installed fine.

The problem is that now I open Nautilus and go to Computer, in there it shows my D partition, 640 Hard Disk, but when I try to mount it displays me a message: "Unable to mount location. Can't mount file".

I ask you to explain me step-by-step what I need to do because I'm not an advanced user.

My computer specs: 2 GiB RAM, Proccesor Pentium(R) Dual-Core CPU E5400 @ 2.70GHz × 2, Graphics Unknow (It's Nvidia GeForce 220 {1GB} or something), OS type 32-bit, Disk 628.0 GB

P.S.: My HDD is internal, I'm not using external Hard Drives.

Thank You!!! Mike

share|improve this question
1  
@rodrigomartins It is not clear if C and D are different partitions or different HDDs. It is also not clear if the OP did a default install or a advanced "Something else install. (He mentions that he doesn't know where Ubuntu is installed in the unedited text.) Ubuntu default install that removes Windows will also remove all partitions in the drive. –  user68186 Dec 21 '12 at 16:36
    
I understood that C and D are different partitions because he said that he doesn't have an external HDD. He specified that he entered in Advanced Installation to format C partition and he said he went 'back (at the installation)' to choose the Install Ubuntu and Replace Windows option. Windows was installed in C, so when Ubuntu replaced Windows, automatically it's alocated in C patition. The partition D remains unaffected as it's just a data partition, the option that removes Windows will only utilize the partition where Windows was intalled. It's what I understood, but I can be wrong. –  Rodrigo Martins Dec 21 '12 at 18:18
1  
Can you provide the output from sudo fdisk -l please? –  user8290 Dec 21 '12 at 18:20
1  
Show Output of uname -a –  totti Jun 2 at 15:55

1 Answer 1

Hmm, if it's still displaying the partition, then that means that it's probably still intact.

Type sudo fdisk -l in the Terminal, and you will get an output like this:

james@james-OptiPlex-GX620:~$ sudo fdisk -l
[sudo] password for james:

Disk /dev/sda: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders, total 312500000 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf475f475

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   196527491    98263714+   7  HPFS/NTFS/exFAT
/dev/sda2       196528126   312498175    57985025    5  Extended
/dev/sda5       308310016   312498175     2094080   82  Linux swap / Solaris
/dev/sda6       196528128   308310015    55890944   83  Linux

Partition table entries are not in disk order
james@james-OptiPlex-GX620:~$ 

In this example, there's a bootable partition at /dev/sda1 of the type NTFS. That's my Windows partition. /dev/sda2 is the Extended Partition that contains my Ubuntu partition (which is at /dev/sda6.) It says that the filesystem type here is Linux, but it's an EXT4 partition.

See if you can figure out which partition is your storage partition. It will probably be FAT, or possibly NTFS.

After you figure that out, note the device it's on (e.g., /dev/sda1.)

Then try typing sudo mount /dev/sda# (replace the # with the number.)

EDIT: I just remembered, you need to install ntfs-3g (the Linux NTFS drivers) for this to work. (sudo apt-get update && sudo apt-get install ntfs-3g)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.