Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please can you help?

I tried to revive my old Dell laptop computer by installing Ubuntu 12.04LTS in place of windows XP. After installing and rebooting, the infamous black/purple screen appears. According to forums its to do with the graphics controller compatibility with the ubuntu OS.

I have already tried the suggestions of gaining access to the GRUB menu during bootup and changing within the parameters of "ubuntu, with Linux 3.2.0-35-generic-pae" where the line that begins with "linux/boot ...", and replacing the mode "quiet splash" with "nomodeset" but without success.

I also tried replacing the "quiet splash" mode with "radeon.modeset=0" mode and that worked but only are few times. The first time it worked and I managed to login to ubuntu, I performed the necessary updates and even changed the GRUB parameters permanently by replacing the "quiet splash" mode with "radeon.modeset=0" thinking that I have solved the problem. But unfortunately the black/pruple screen reappeared even with the "radeon.modeset=0" mode already set permanently (which was really odd!). Now even with the GRUB parameters switched back permanently to "quiet splash" mode in one of the rare successful login attempts I was never able to login again successfully using "radeon.modeset=0".

The Dell inspiron 1100 laptop consists of an intel celeron CPU, 2.20GHz, 32-bit OS type, 1 gigabyte RAM, 60 gigabyte hard disk, with a 15-inch monitor. The video type is a direct AGP integrated graphics, video controller is an intel UMA integrated, and graphics controller is an intel 845GX86/MMX/SSE2.

Using the ubuntu 12.04LTS liveCD works fine on the PC, only when installing the ubuntu 12.04LTS permanently on the PC is when the black/purple screen appears!

Philley

share|improve this question
    
Possible duplicate of: askubuntu.com/questions/162075/… –  user68186 Dec 21 '12 at 15:15
    
Did you run sudo update-grub and sudo update-grub2 after modifying /etc/default/grub? Did you save after modifying the file (it's amazing the silly mistakes we all make sometimes)? Hope you get it fixed! –  Josh Dec 22 '12 at 4:38
    
Thanks Josh for the input. –  user115915 Dec 28 '12 at 3:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.