Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've run into problems with Grub 2 on a family computer. I recently installed Lubuntu as the machine was too old to run Ubuntu nicely and my family don't really need it to do anything beyond run BBC iPlayer and not crash.

But frustratingly, I can't get it to boot quickly because despite GRUB_TIMEOUT=0, the GRUB2.00-7~ screen just sits there until you manually select the first option.

Any tips? I'm sure it must be something simple, but I can't find a similar thread. I don't have a LiveCD to reinstall, was installed a while ago by USB, and I'd rather not risk goin in alone/blind with commands that could render the system unusable...

So is there a... like, a default grub that I can copy and paste over the existing grub.cfg text and sudo update-grub?

Edit: my grub looks ilke this:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=1
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I've been using sudo leafpad /etc/default/grub to edit.

Many thanks for your time and your understanding.

share|improve this question
    
It may be useful if you were to post the contents of your /etc/default/grub here so that we can see what is wrong with it. –  Paddy Landau Dec 21 '12 at 13:51
    
See this answer. –  To Do Dec 21 '12 at 14:21
add comment

1 Answer 1

Try this:

#/boot/grub/grub.cfg
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
set timeout=0

The "recordfail" part is to prevent the system from booting up after e.g. a power loss. So if this works your family might be shutting down the computer incorrectly. There are probably better ways to solve this but I've seen many recommend this (and I even use this on my home server since I want it to automatically boot up when the power comes back on).

share|improve this answer
    
This worked for me. But I am at loss why ubuntu decided an unclean shutdown even when i give a reboot or shutdown -r now command. –  Jamess Jan 24 '13 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.