Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to compile qemu 1.3 with ubuntu 12.04 with spice enabled, I get this error:

ERROR
ERROR: User requested feature spice
ERROR: configure was not able to find it
ERROR

I have read around and it seems I should edit pkg config path? I am running ubuntu, I tried changing pkg config but I am guessing...help?

share|improve this question
add comment

1 Answer

You need to install spice-protocol first. Unfortunately (atleast on 12.10) it is not available in the main repositories, so you will have to download and compile it:

wget http://spice-space.org/download/releases/spice-protocol-0.12.3.tar.bz2
tar -xjf spice-protocol-0.12.3.tar.bz2
cd spice-protocol*
./configure
make
sudo make install

If you prefer you can use git:

git clone git://git.freedesktop.org/git/spice/spice-protocol

If you have build-essentail installed, the compilation should go without any problem.

After this just proceed to the compilation of qemu enabling spice, passing --enable-spice to configure:

./configure --enable-spice
# make & make install

Hope this helps.

share|improve this answer
    
I have both installed spice-protocol and spice server: pkg-config spice-protocol --modversion 0.12.3 pkg-config spice-server --modversion 0.12.2 –  user1640204 Dec 21 '12 at 15:53
    
what is the output of pkg-config --cflags spice-protocol spice-server? –  Salem Dec 21 '12 at 16:14
    
I didn't have the latest spice, so I installed it and now it is working –  user1640204 Dec 22 '12 at 17:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.