Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can connect to internet by modem, when i plug the device before booting.After unplugging and when try to re plug the modem after log in,there is no enable mobile network option and i cannot connect to the internet.Can anyone help me ?....

share|improve this question

closed as too localized by qbi, Eric Carvalho, Ringtail, jrg Jan 16 '13 at 2:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
how can you connect before booting? –  don.joey Dec 21 '12 at 9:55
    
connecting the modem to the computer,not to the internet –  AbiRAM02 Dec 21 '12 at 9:59
    
What modem do you use? –  qbi Jan 13 '13 at 13:28
    
I'm not sure why you'd classify this one as "too localised" when it affects anyone doing a 12.04 LTS install and relying on wireless broadband and network manager. Possibly, you'd say it was off-topic because it's a bug, except the work-arounds might actually help someone and I'd still argue it should be left available since it's not obviously a bug. –  fabricator4 Jan 16 '13 at 3:42
    
@fabricator4 It's still available. There's no restriction on searching/viewing closed questions. It's answered so it won't be deleted automatically. Even manual deletion would need more votes than usual, as the total question+answer score here is 5 (and anyone who thinks this is valuable can upvote). I think, to the extent to which this is not too localized, it's OT as a bug. Workarounds belong in the bug, where they can stay up to date and help all the other people there. It's linked here, so anyone here can get to it. However, if you think we should reopen, you may want to post on meta. –  Eliah Kagan Jan 16 '13 at 11:11

1 Answer 1

There's a bit of a bug in Network Manager 0.9.4.0 that prevents it from detecting the 3G modem all of the time. I had this intermittent problem with the built-in Huawei modem in my EeePC. The problem seems to have been resolved with Network manager 0.9.6.0 which ships with 12.10.

You should try restarting Network Manager in the first instance. In a terminal:

sudo service network-manager restart

and see if that enables the 3G modem when you insert after booting.

Consider upgrading to 12.10, installing Network Manager 0.9.6.0 (into 12.04 LTS), or wait until the later Network Manager 0.9.6.0 is upgraded in 12.04 LTS. Version upgrades can take a while to be incorporated into previous releases, even (or especially) LTS ones. I believe this will happen, but it probably won't be until this bug is also fixed to everyone's satisfaction.

3G has been a rocky road since 11.04, I'm afraid. As stated in that bug, you will have to enable Wireless broadband again after every boot or resume. There's a nice work-around that works for a clean boot however.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.