Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Occasionally my mouse / keyboard would take extra long to respond to input. If I moved the mouse or pressed a key it would take an extra second to respond the work normally.

If I leave it alone for a period of time the it happens again.

In the dmesg log I see entries like this

dmesg | tail

ehci_hcd 0000:00:1d.0: PCI INT A disabled  
ehci_hcd 0000:00:1d.0: PME# enabled  
ehci_hcd 0000:00:1d.0: BAR 0: set to [mem 0xd9105800-0xd9105bff] (PCI address [0xd9105800-0xd9105bff])  
ehci_hcd 0000:00:1d.0: restoring config space at offset 0xf (was 0x100, writing 0x10b)  
ehci_hcd 0000:00:1d.0: restoring config space at offset 0x1 (was 0x2900000, writing   0x2900002)  
ehci_hcd 0000:00:1d.0: PME# disabled  
ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21  
ehci_hcd 0000:00:1d.0: setting latency timer to 64  

I found out which device it is but still don't know what is actually causing the issue. I know it has some thing to do with the usb controller.

lspci -n | grep 00:1d.0
00:1d.0 0c03: 8086:3b34 (rev 05)

lspci -d 8086:3b34
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)   

UPDATE

After a bit of investigation I believe it has some thing to do with power management, power saving or auto suspend of the device.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

After quite a bit of googling I remembered I has installed powernap.

sudo powernap-action -l

[disabled] 01cpu_online         - sh: 1: /etc/pm/power.d/01cpu_online: Permission denied  
[enabled]  00flag               -  
[disabled] usb                  - sh: 1: /etc/pm/power.d/usb: Permission denied  
[disabled] video                - sh: 1: /etc/pm/power.d/video: Permission denied  
[disabled] eth_speed            - sh: 1: /etc/pm/power.d/eth_speed: Permission denied  
[enabled]  usb_autosuspend      - Auto suspend USB bus to save power.  
[enabled]  cpu_frequency        - Lowers the CPU frequency, changing the scaling governor from ondemand to powersave.  
[disabled] kms_powermode        - sh: 1: /etc/pm/power.d/kms_powermode: Permission denied  

One of the options I had enabled was

[enabled]  usb_autosuspend      - Auto suspend USB bus to save power.

So I fixed the issue by disabling usb_autosuspend.

sudo powernap-action --disable usb_autosuspend

So Now

[disabled] usb_autosuspend      - sh: 1: /etc/pm/power.d/usb_autosuspend: Permission denied
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.