Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

During a complete fresh installation I choosed a case sensitive password with an "!" inside the string, it works fine for the normal login, but when I try to use sudo or su or passwd or some GUI stuff which requires a password I get an authentication error.

I really have no idea what to do, I tried to enter the password in an editor to check numlock, etc... no problem.

After the login I get an error (ca. 1 minute after login), in german:

"Es wurde ein Problem mit einer Systemanwendung festgestellt"

Something like:

"There is a problem with a system process/program"

share|improve this question
    
How do you know the "problem with a system process" is related to your password problem? –  don.joey Dec 21 '12 at 9:16
add comment

1 Answer 1

It looks like your root keyboard layout is different from your user's. In that case, do the following.

First, open the Language Support in System Settings. Press the «Apply System-Wide» button.

Second, open the Keyboard Layout in System Settings. Check the «Use the same layout for all windows» option.

Restart

share|improve this answer
    
i can't do step 1 because i need to enter my password (tried to google us keyboard layout, but it seems that the "!" is at the same place like in germany, at the "1") –  Milo Tischler Dec 21 '12 at 3:16
    
@MiloTischler. I think you don't have a problem only with the «!». Remember that the US layout is QWERTY, while the common german is QWERTZ. You can also try to add the US Keyboard Layout in System Settings (step two supra) or at least see the «Preview» of it. Otherwise, I suggest that you run an Ubuntu LiveCD and type your password in a simple text editor (to see the differences in the layout and figure out what was the combination you actually typed) –  Ed Villegas Dec 21 '12 at 5:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.