Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Been looking around and can't see to find any information on how to enable alt+right click for window resize?

edit

My mistake

Running Unity 12.04, I am logged in under failsafe graphics mode as i can't get my 590GX Nvidida card to boot up without being in safe, but thats another problem.

Currently, my alt+click works and i can drag windows around.

But i can't currently, alt+right-click to resize.

share|improve this question
    
It should work out of the box, without modifications. Please provide more information: what desktop environment are you on (Unity/KDE/GNOME/XFCE/LXDE/...)? Did you update your installation? Did you try to create a new user, log in as the new user and see if that works? –  gertvdijk Dec 20 '12 at 23:02
    
edited, should make more sense. –  Jamie Hutber Dec 20 '12 at 23:19
    
Did you check the compiz resize settings(plugin)? –  Weylin Schreck Dec 21 '12 at 0:35

3 Answers 3

up vote 3 down vote accepted

Install compizconfig-settings-manager

sudo apt-get install compizconfig-settings-manager

and run ccsm from the Dash or from a Terminal window.

ccsm

Click Window Management and Resize Window.

For 🐭 | Initiate Window Resize assign <Alt>Button3.

share|improve this answer
    
Thanks, awesome stuff :) –  Jamie Hutber Jan 11 at 0:16
    
This also works for 14.04. –  brejoc Jun 3 at 19:42

Here is the solution I found:

Use gconf-editor and set /apps/metacity/general: resize_with_right_button = true

share|improve this answer

The answer from here describes a method that works in both 12.04 (and possibly older versions) as well as 12.10/13.04 with the new gsettings

Put this in a script and run it:

#!/bin/bash
gconftool-2 -s -t bool /apps/metacity/general/resize_with_right_button true
gsettings set org.gnome.desktop.wm.preferences resize-with-right-button true

The gconftool-2 line is for GConf based systems, and gsettings is its newer replacement.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.