Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm looking for a way to tell Firefox to use a proxy in Ubuntu Ludid (10.04.1 LTS).

I'm installing Ubuntu semi-automatically on several identical machines. For this, I use a script that, amongst other things, sets system-wide proxy settings:

echo "export http_proxy=http://myproxy:3128/" > /etc/profile.d/proxy.sh
echo "export HTTP_PROXY=http://myproxy:3128/" >> /etc/profile.d/proxy.sh
chmod a+x /etc/profile.d/proxy.sh

I can confirm that the variables are set correctly when checking in a shell. Most programs respect this setting and use my proxy. Firefox, however, does not. When I open its network connection settings dialog, however, it is pre-set to "use system settings" for the proxy.

What does Firefox expect here? A differently-named variable? Can I set something in FF's prefs.js?

share|improve this question
add comment

3 Answers

up vote 15 down vote accepted

Firefox just can't do the standard thing and use environment variables (though to be honest this is partly justified as the standard thing doesn't allow for proxy autoconfiguration files). The preferences for static proxies are

user_pref("network.proxy.http", "wwwproxy.example.com");
user_pref("network.proxy.http_port", 3128);
user_pref("network.proxy.type", 1);

There's a Firefox extension to use $http_proxy and similar environment variables: Environment Proxy.

Recent versions of Firefox supposedly use the usual environment variables by default, or if the proxy type preference is explicitly set to 5 (“Use system proxy settings”), but it doesn't work for me with the version in Ubuntu 10.04.

user_pref("network.proxy.type", 5);
share|improve this answer
1  
Thanks for your answers. After Gilles' hint that FF just doesn't use environment variables, I went to the Firefox's bugtracker and found this entry: bugzilla.mozilla.org/show_bug.cgi?id=224886 So the problem is known upstream. Since 2003. –  jstarek Jan 25 '11 at 0:41
add comment

According to a listing of commandline options there is no explizit option for a proxy. As you found out also neither http_proxy nor something alike works. I would suggest to first create a profile:

firefox -CreateProfile foo

Next you can use sed or whatever tool you like to write user_pref("network.proxy.http", "YOUR_PROXY"); user_pref("network.proxy.http_port", PORT); to prefs.js. Now Firefox should work fine with those proxies.

share|improve this answer
add comment

You say 'proxy', but your examples indicate you probably mean 'HTTP proxy' specifically. However, if you also have access to a SOCKS proxy, which does not forbid HTTP traffic, you could use the tsocks tool:

tsocks firefox

once you have configured /etc/tsocks.conf suitably.

share|improve this answer
    
Thanks for the hint. Yes, I should have specified that better: There's a caching proxy for http (squid) I need to use. –  jstarek Jan 25 '11 at 14:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.