Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently moved to Ubuntu from Windows, and the very only thing I couldn't find an acceptable replacement to was foobar2000. While there are plenty of awesome audio players around in the ubuntu world, I couldn't settle for one of them to replace foobar2k.

So I decided to install it (version 1.1.18) in my Ubuntu Gnome Remix 12.10 64 bits through wine (1.4.1 amd64), and to my great surprise... The result was excellent, better than expected after reading the app review in the WineHQ database!

The only thing that I found doesn't work properly, is the multimedia hotkey keybindings. I have a Dell Studio 1745 laptop with a couple of multimedia keys (Mute, VolumeDown/Up, PlayPause etc); while they are perfectly recognized in standard Ubuntu apps (gmusicbrowser, foobnix got them), I couldn't find a way to have foobar2000 react to them through wine (with or w/out focus on f2k window).

I've tried to follow instructions given at http://ubuntuforums.org/showthread.php?t=690301 but the steps from the first link don't match with my system, and although I did find in dconf editor the right menu (org.gnome.desktop.wm.keybindings), I wasn't able to find a way to instruct a new shorcut for wine [foobar2000 path]/foobar2000.exe /next etc.

Is there something I should change in wine, to transmit the multimedia hotkeys hits? Thanks a lot!

share|improve this question
    
are the foobar2000 keyboard commands under 'Preferences/Keyboard shortcuts' working for you? – cipricus Jun 24 '13 at 17:12

I just had a similar problem trying to get keyboard shortcuts working with Foobar2000 in Linux Mint. The issue was that the working directory for the keyboard shortcuts was the system root directory and not my home directory, and ~/ paths weren't working.

In other words, I had been putting in the path as:

wine ~/WinPrograms/Foobar2000/foobar2000.exe /playpause

Or:

wine /WinPrograms/Foobar2000/foobar2000.exe /playpause

But I had to use:

wine /home/[myusername]/WinPrograms/Foobar2000/foobar2000.exe /playpause
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.