Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After deciding to install Ubuntu (12.04) on a newly bought Netbook (Acer Aspire One 756 with Intel Dual Core 847 and 2 GB RAM, Linpus linux pre-installed), I have had trouble getting it done.

I have created a bootable USB Stick witch Ubuntu 12.04 (which works fine for my desktop machine) with pendrivelinux. However, I am not able to boot from that USB stick.

I am aware of a similar case (http://askubuntu.com/questions/196831/acer-aspire-one-756-with-pentium-b967), however the solution there (switch boot mode to "Legacy" in BIOS) does not work for me: There simply is no adjustable "Boot mode" in the BIOS. Yes, I really tried hard to spot it! I can change the boot order so that it has my USB stick on the top of the list, but it won't boot from the USB stick anyway.

Hopefully, I have not overlooked any answers when searching for a solution. Apart from the question I mentioned above, I could not find a fitting thread.

Any help with this matter would be greatly appreciated. Thanks in advance!

EDIT: For me the issue is solved in so far as I managed to install Ubuntu 12.10 (see comment below).

share|improve this question
1  
When you try to boot from the USB, does it give you some error such as something related to Secure boot or signature error? That may be due to UEFI if it's new hardware. –  Addison Montgomery Dec 20 '12 at 18:39
    
Thanks for the quick answer. I did not get any error message. It just went straight to the linpus linux which is installed on the hard disk. –  Moritz Dec 20 '12 at 19:41
    
I tried a variety of (mostly older) USB sticks and failed. Then I did the same with Ubuntu 12.10. With two USB sticks I failed again, but the third one worked and I got through the installation. Dunno if it's 12.10 instead of 12.04 or if it was just the right choice of USB stick... –  Moritz Dec 20 '12 at 20:08

2 Answers 2

I have an Acer Aspire One 756 Windows 8 preinstalled and UEFI secure mode ON and I solved this problem.

  1. Download an Ubuntu 13.04 64 bit version

  2. Create a bootable USB with that Linux

  3. Go to BIOS (press F2 to startup) and set a supervisor password doing so many menu options below will unlock

  4. Set USB HDD first boot and disable secure mode

  5. Reboot Linux and select try Linux (NO INSTALL)

  6. Start GParted and use that to shrink Windows 8 partition (the most large one) to 20 gb

  7. Into the free space created, create a 15 gb EXT4 partition and a 512 MG swap

  8. Then start Linux installation and use OTHER option

  9. Choose the new ext4 partition as / mount point and flag it to be formatted

  10. DON'T touch grub installation partition. It should be /dev/sda. Leave it alone !!

  11. Continue installing normally then reboot

  12. Windows 8 will boot up DON'T worry !! This is normal and is a check to see if win 8 is there !!

  13. Reboot Windows 8 and press F2 to enter BIOS at startup

    • re enable secure mode !!
  14. Go to security menu and use "add uefi executable as secure for boot" option here you will see many folders , go to ubuntu an chose the ubuntu uefi file

  15. BIOS now asks to add it as secure boot uefi firmware into database and to set up a new name for it (set ubuntu or pluto ... or whatever you want)

  16. save setting and reboot

  17. Hit F12 on boot and you will see a new entry (ubuntu or pluto or whatever you put on section 15)

  18. Select that one and UBUNTU will boot strap correctly

I'm writing this guide using exactly my brand new Ubuntu on Acer Aspire One 756

If you boot computer normally Windows 8 will boot !!

share|improve this answer

On most computer there is a key you can press while booting to load a boot menu. In many systems it F12 or some other function key.

On some other Acer's it is F12 that brings up the boot menu. Give it a try.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.