Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 12.10 on my new Windows 8 Dell Inspirin and would like to set up a Dual Boot. However, when I restarted, it just went straight to Windows 8 without giving me a Grub screen with options to start Ubuntu. I haven't had luck with EasyBCD or the BootRepair utility.

Any idea how I can get a Dual Boot working?

share|improve this question

New computers which come with Windows 8 use UEFI, a try to replace the old BIOS firmware. You can read about this on Ubuntu wiki, but I'll paste you some things you can try to do.

  1. Create a LiveDVD or LiveUSB of Ubuntu-Secure-Remix 64bit or of Ubuntu (>=12.10) 64bit. The former is more convenient, as it already includes Boot-Repair, which is used in step 4.

  2. Boot your PC using the LiveDVD or LiveUSB and choose "Try Ubuntu". Remark: if you get a Secure boot or signature error, disable SecureBoot as described here, then retry to boot the disk. You may also need to disable QuickBoot in the same menu. Install Ubuntu from the Live CD/DVD or Live USB in the usual manner, then reboot the PC.

  3. If the PC does not load Ubuntu (but instead loads Windows, for example, as in Bug #1050940), or if the Windows entry in the GRUB 2 menu does not boot Windows (see Bug #1024383), boot your PC using the Live CD/DVD or Live USB and choose "Try Ubuntu" once again. When the live session has loaded, run Boot-Repair (see link for details). When Boot-Repair loads, click on the "Recommended repair" button, and write on a paper the URL ( that will appear.

  4. This should fix most boot problems. If this does not fix your boot problems, please follow this procedure. If still not good, please create a new thread in this forum, describing your problem and indicating the URL you wrote in the previous step.

share|improve this answer

I had pretty much the same problem and the solution was to

  • disable the secure boot option in the UEFI; then
  • Open Ubuntu by interruptiong the boot up (hopefully for the last time)
  • run Boot-Repair (which you've already got) using the "Recommended Repair" option as already explained above.

See more details here

I found that if you don't disable the secure boot option GRUB does not run on boot up and the machine loads Win8 by default.

Good luck :-)

share|improve this answer

I hope you have followed this procedure to install Ubuntu.

If yes..You can do a Grub rescue by following this link.

share|improve this answer

For those encountering the same issue, the first thing to try might be simply to change the boot priority order in the BIOS.

I had the same problem with an Acer Aspire V3 with W8, after I installed Ubuntu 16.04. After powering on the computer I pressed F2 to get the boot menu (it might be something else, F12 or esc on other computers), then selected the tab 'boot', then moved up Ubuntu in the list by selecting it and pressing F6.

But of course other cases might not be so easy to fix ...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.