Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am relatively new at using Linux and have just installed a fresh(ish) copy of Ubuntu 10.04.1 LTS Minimal install running on a HyperVM VPS.

How would I enable ACL? I have a question on Superuser which resolved the problem I was trying to solve on a virtual machine running Ubuntu Server 10.10.

df -T yields /dev/simfs of type reiserfs - What would I put in fstab to mount ACL for the file system? At the moment this file is blank.

after running sudo mount -o remount,acl / I get mount:permission denied. Any suggestions?

Edit

Marked as solved as from all the research that I have done it's been concluded that I am unable to use ACL's on a VPS due to permissions.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Reiserfs simply doesn't have support for access control lists. At least not according to http://en.wikipedia.org/wiki/Comparison_of_file_systems#Metadata

EDIT: As grawity points out in the comments, it appears to have support for so-called POSIX ACLs, despite what that wikipedia-page says.

The permission denied message is a bit odd, then. I suspect the VPS adds some restrictions regarding that. Have you tried adding the acl option in /etc/fstab, and then rebooted?

Each line of the /etc/fstab file has six fields separated by whitespace (excluding lines that start with #, which are ignored). On the line where the second field is /, add ,acl to the end of field 4. E.g. if field 4 just says defaults, change it to defaults,acl.

After you've rebooted, run mount, and check if it has been mounted with the acl option.

share|improve this answer
2  
According to the article on ReiserFS, the manual page of mount(8), and my tests, ReiserFS does support ACLs. –  grawity Jan 25 '11 at 16:19
    
Indeed, you are right. I should've been more critical to trusting that wikipedia page that quickly. –  geirha Jan 25 '11 at 18:25
    
I contacted my VPS provider and they said it's a limitation as you are unable to perform these sorts of things due to the security limitations:/ –  Malachi Jan 26 '11 at 20:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.