Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the following error when updating my ubuntu:

$sudo apt-get upgrade

[...]
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites : 
postgresql-client-9.1 : Casse: postgresql-9.1 (< 9.1.7-0ubuntu12.04) mais 9.1.6-1~precise2 est installé
postgresql-contrib-9.1 : Dépend: postgresql-9.1 (= 9.1.7-0ubuntu12.04) mais 9.1.6-1~precise2 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

$sudo apt-get -f install

dpkg : des problèmes de dépendances empêchent la configuration de postgresql-9.1 : postgresql-client-9.1 (9.1.7-0ubuntu12.04) casse postgresql-9.1 (<< 9.1.7-0ubuntu12.04) et est installé.
La version de postgresql-9.1 à configurer est 9.1.6-1~precise2.
dpkg : erreur de traitement de postgresql-9.1 (--configure) :  problèmes de dépendances - laissé non configuré

Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                         dpkg : des problèmes de dépendances empêchent la configuration de postgresql-contrib-9.1 :
postgresql-contrib-9.1 dépend de postgresql-9.1 (= 9.1.7-0ubuntu12.04) ; cependant : La version de postgresql-9.1 sur le système est 9.1.6-1~precise2.
dpkg : erreur de traitement de postgresql-contrib-9.1 (--configure) : problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :  
postgresql-9.1
postgresql-contrib-9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am using postgre-sql with QGIS (& had a hell of a hard time to install everything as to everything work fine), it worked good for a few months and now (since this morning) I have this problem and I don't know what to do??... I tried to desactivate the ubuntugis-unstable repository and perform "sudo apt-get -f install" but with no success... I checked on the internet without finding my specific problem....

Unfortunately I'm not a ubuntu expert so I'm hoping to get an advice from one of you... I hope the solution is not to uninstall everything...

Thank you for your help!

share|improve this question

3 Answers 3

Try the apt-get update, apt-get upgrade again, the postgresql packages were just updated and you might have caught them in an inconsistent state.

Still problems, try installing the packages explicitly. If that fails, (backup any databasese) remove the packages, then apt-get autoremove and try installing them again.

share|improve this answer
    
Thank you for your answer but now the package system is broken apt-get update & upgrade still don't work.... and I don't know what should I do.... (Error message: The following packages have unmet dependencies: postgresql-client-9.1 and : postgresql-9.1 (= 9.1.7-0ubuntu12.04)) –  Lane Dec 23 '12 at 13:49

Sorry I can't help with fixing your problem, but if you do have to re-install postgis you may find this script helpfull

#!/bin/bash -x

set -eux

apt-get install -y postgresql-9.1 apache2 python-setuptools postgresql-server-dev-9.1     postgresql-9.1-postgis postgis binutils libproj-dev gdal-bin git unzip

#==================================================#
# setup the posgis template for postgresql
#==================================================#
GEOGRAPHY=0
POSTGIS_SQL=postgis.sql

if [ -d "/usr/share/postgresql/9.1/contrib/postgis-1.5" ]
then
    POSTGIS_SQL_PATH=/usr/share/postgresql/9.1/contrib/postgis-1.5
    GEOGRAPHY=1
fi

su postgres -c "createdb -E UTF8 template_postgis" && \
su postgres -c "( createlang -d template_postgis -l | grep plpgsql || createlang -d template_postgis plpgsql )" && \
su postgres -c "psql -d postgres -c \"UPDATE pg_database SET datistemplate='true' WHERE datname='template_postgis';\"" && \
su postgres -c "psql -d template_postgis -f $POSTGIS_SQL_PATH/$POSTGIS_SQL" && \
su postgres -c "psql -d template_postgis -f $POSTGIS_SQL_PATH/spatial_ref_sys.sql" && \
su postgres -c "psql -d template_postgis -c \"GRANT ALL ON geometry_columns TO PUBLIC;\"" && \
su postgres -c "psql -d template_postgis -c \"GRANT ALL ON spatial_ref_sys TO PUBLIC;\""

if [ $GEOGRAPHY -eq 1 ]
then
    su postgres -c "psql -d template_postgis -c \"GRANT ALL ON geography_columns TO PUBLIC;\""
fi

You will likely have to run it as using sudo.

share|improve this answer

Try to use dpkg --force-depends --purge , it helped me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.