Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Valve's steam client is now Open to all said a link and so I decided to install Steam Client on my Ubuntu 12.04 machine to try it out.

I downloaded the deb file from this page.

Once after the download is completed and I double-clicked to install it and as expected Ubuntu software Centre is launched but with error as stated below:

Internal Error "The file /home/pras/Downloads/steam_latest.deb can't be opened".

Even I tried to install it via

sudo dpkg -i steam_latest.deb

which also throws errors

pras@Tuxbox:~/Downloads$ sudo dpkg -i steam_latest.deb 
[sudo] password for pras: 
(Reading database ... 408406 files and directories currently installed.)
Unpacking steam (from steam_latest.deb) ...
dpkg-deb (subprocess): short read on buffer copy for failed to write to pipe in copy
dpkg-deb: error: subprocess paste returned error exit status 2
dpkg: error processing steam_latest.deb (--install):
 short read on buffer copy for backend dpkg-deb during `./usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz'
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Errors were encountered while processing:
 steam_latest.deb

So how should I install it?

share|improve this question
1  
maybe the downloaded file is just corrupt? Try download a fresh copy and install it again. –  Salem Dec 20 '12 at 13:56
    
Well, thanks for pointing out it. There seems to be a problem with their server. The file is around 5 MB while the download get interrupted at random places on every download I try again and again. For 1st time it stopped at 35% and next time 62% and something like that. So the problem is due to Incomplete download of the file. –  Prashere Dec 20 '12 at 14:12
    
use wget as stated by nighthawk. wget -c http://media.steampowered.com/client/installer/steam.deb. If the download stops at the middle wget will be able to continue it. –  Salem Dec 20 '12 at 19:06

1 Answer 1

up vote 8 down vote accepted

I had this same problem.

To get around it I used 'wget' in a terminal to download the file.

When the interruption happened 'wget' just reconnected and continued to download the file.

I used the following command

wget http://repo.steampowered.com/steam/archive/precise/steam_latest.deb

share|improve this answer
    
+1 Using wget to download worked better for me than using a web browser. Also note that using the dpkg command instead of trying to open the .DEB with the software center worked better too. –  Ed Manet Dec 20 '12 at 17:36
    
I used Flareget to get the work done. Anyway thanks to Salem, nighthawk-uk and Ed Manet –  Prashere Dec 24 '12 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.