Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Thinkpad Edge S430. I was using ubuntu 12.10 a bit more than a month. Everything was working fine. On 20th of december updated and upgraded ubuntu, no issues. Soon after that I suspended my laptop and when I activated it and logged in the touchpad and the trackpoint was unresponsive. I mean completely not working. Since I also have Windows 8 on the machine, I tried also there. The same issue. Even tried live boot of windows... Nothing. I really dont know how it happened. Could the ubuntu update and upgrade cause this? Also tried disabling and enabling in bios, but the problem was that there is no entry about touchpad. However I read somewhere that some with some thinkpads, the bios doesnt have this entry at all. But I dont know if my machine should or should not contain this entry. Also it's worth to mention that whenever I uninstall the touchpad driver in Windows, reboot it, it prompts me to restart again, since it detect new hardware, that it is the touchpad. Updating driver didnt worked.

Read a lot of forums with different solutions like Fn+F#, also a list of sudo commands that should enable the touchpad. Nothing what so ever.

Here is the list of updates and upgrades I made that day

Start-Date: 2012-12-19 14:22:36 Commandline: apt-get install ibam Install: ibam:amd64 (0.5.2-2.1ubuntu1) End-Date: 2012-12-19 14:22:46

Start-Date: 2012-12-19 15:36:02 Commandline: apt-get install insync-beta-ubuntu Install: insync-beta-ubuntu:amd64 (0.9.30), xdotool:amd64 (2.20110530.1-3ubuntu1, automatic), libxdo2:amd64 (2.20110530.1-3ubuntu1, automatic), gir1.2-nautilus-3.0:amd64 (3.5.90.really.3.4.2-0ubuntu4, automatic), python-nautilus:amd64 (1.1-3, automatic) End-Date: 2012-12-19 15:36:24

Start-Date: 2012-12-19 16:42:50 Commandline: apt-get upgrade Upgrade: libglib2.0-data:amd64 (2.34.0-1ubuntu1, 2.34.1-1ubuntu1), wine1.5-i386:i386 (1.5.19-0ubuntu1, 1.5.19-0ubuntu3), libgpod-common:amd64 (0.8.2-6build1, 0.8.2-6ubuntu1), wine1.5:amd64 (1.5.19-0ubuntu1, 1.5.19-0ubuntu3), libgpod4:amd64 (0.8.2-6build1, 0.8.2-6ubuntu1), libglib2.0-0:amd64 (2.34.0-1ubuntu1, 2.34.1-1ubuntu1), libglib2.0-0:i386 (2.34.0-1ubuntu1, 2.34.1-1ubuntu1), wine1.5-amd64:amd64 (1.5.19-0ubuntu1, 1.5.19-0ubuntu3), libglib2.0-bin:amd64 (2.34.0-1ubuntu1, 2.34.1-1ubuntu1), shutter:amd64 (0.89.1~ppa4~quantal1, 0.90~ppa4~quantal1) End-Date: 2012-12-19 16:43:30<

I hope someone has an idea what happened and ho to fix this. Thanks.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.