Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Always when I install something, I get the following error multiple times:

Unknown configuration key 'foreign-architecture' found in your 'dpkg' configuration files. This warning will become a hard error at a later date, so please remove the offending configuration options and replace them with 'dpkg --add-architecture' invocations at the command line.

When I try dpkg --add-architecture I get:

Unknown configuration key `foreign-architecture' found in your `dpkg'
configuration files.  This warning will become a hard error at a later
date, so please remove the offending configuration options and replace
them with `dpkg --add-architecture' invocations at the command line.

dpkg: error: --add-architecture takes one argument

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !

I've no problems yet, but since it says This warning will become a hard error at a later date I better do something about this. When I search 'foreign-architecture', I find an empty file, containing not a single byte. I somehow can't delete that file.

Please help, it's a kind of creapy...

I use Ubuntu version 12.10

Updated the questions:

cat /etc/dpkg/dpkg.cfg 
no-debsig 
log /var/log/dpkg.log

ls /etc/dpkg/dpkg.cfg.d/
multiarch 
share|improve this question
    
Post the results of cat /etc/dpkg/dpkg.cfg & ls /etc/dpkg/dpkg.cfg.d/ . Re-edit your question. –  NikTh Dec 20 '12 at 13:33
    
for cat: # dpkg configuration file # # This file can contain default options for dpkg. All command-line # options are allowed. Values can be specified by putting them after # the option, separated by whitespace and/or an `=' sign. # # Do not enable debsig-verify by default; since the distribution is not using # embedded signatures, debsig-verify would reject all packages. no-debsig # Log status changes and actions to a file. log /var/log/dpkg.log For ls: multiarch –  speedy-MACHO Dec 20 '12 at 14:34
    
Please edit your question and add the results between code tags. Cannot read anything like that. –  NikTh Dec 20 '12 at 14:51
    
Please update the question with the following information: Ubuntu version, architecture (uname -m) and the oputput of cat /var/lib/dpkg/arch. –  Eric Carvalho Dec 20 '12 at 17:32
    
sorr, what do you mean with 'architecture (uname -m)'? and cat /var/lib/dpkg/arch gives: No such file or directory. I don't think I have to write that down? By the way, if you want to edit, just do it. –  speedy-MACHO Dec 20 '12 at 18:22
show 2 more comments

1 Answer 1

You say in the comments that you see:

$ ls /etc/dpkg/dpkg.cfg.d/
multiarch

Presumably that file, /etc/dpkg/dpkg.cfg.d/multiarch, contains a foreign-architecture key. So I suggest just deleting the file:

sudo rm /etc/dpkg/dpkg.cfg.d/multiarch
share|improve this answer
    
As you've said in another comment this file is not being used anymore on 12.10. I assume this is just a leftover from the upgrade from 12.04 of the OP. –  gertvdijk Jan 15 '13 at 14:09
    
It should have been cleaned up on upgrade –  tumbleweed Jan 15 '13 at 14:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.