Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Disclaimer First:

Now the Problem

I have installed Ubuntu 12.10 (64bit) in this Sony Vaio laptop. After vanilla isntallation the brightness keys are working and I can see the brightness indictaor going up and down but it isn't having any effect on the real brightness of the device.

I have installed additional drivers too but that didn't solve the problem. I can't seem to be able to change the brightness.

Anyone knows how I can fix this?

share|improve this question
This might help. I also had the same problem with my sony vaio. I found the solution here.… – imankurpatel000 Jan 26 '13 at 15:33
@imankurpatel000 the link you provided just points me to another link where I have the same set of instructions(posted here) which doesn't help at all. – Rabimba Karanjai Jan 30 '13 at 10:15
Sorry the link was wrong. Here is the original:… – imankurpatel000 Jan 31 '13 at 15:47
I ahve tried that solution. Sadly it didn't work for me :( – Rabimba Karanjai Apr 29 '13 at 8:15

Try modifying /etc/default/grub changing the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Then run sudo update-grub

If it doesn't work try changing the same line to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" and update-grub again.

share|improve this answer
I tried doing both of them. And None of them worked. The only thing they did was to disable the brightness hotkeys in my keyboard. I've tried editing the [code]/etc/X11/xorg.conf[/code] file but in my case it's a blank file (I'm uisng ATI card) – Rabimba Karanjai Dec 21 '12 at 2:38
This might help. – To Do Dec 21 '12 at 8:16
Isn't that for FW series? – Rabimba Karanjai Apr 29 '13 at 8:16

the only way to change brightness is to use this command

sudo su

echo 150 > /sys/class/backlight/intel_backlight/brightness

all other solution does not work at the moment. this is not my work around. i dont remember where i got this but it works and hats off to the person who gave this workaround :)

Using Ubuntu 13.10 64Bit Wubi on Lenovo Z570

share|improve this answer
Please do not post the same answer to multiple questions. If the same answer fits on multiple questions, flag the latest one as a duplicate. – RolandiXor Oct 24 '13 at 5:34
up vote 0 down vote accepted

I was finally able to solve the issue. Hence posting for the help of others coming to this post using search.

None of the techniques shown above worked for me. But goto the AMD's website (I have Radeon 7670 HD) and download their linux BETA driver which will solve your issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.