Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently having a problem with my wireless. Whenever I try to download anything it kills the internet for every other application(tabs within the same browser, browsers on other computers on the same network) except the process doing the download. This occurs with everything from downloading updates to iso's. I am not using a torrent. It happens when downloading upgrades, browser downloads, or anything else. This problem does not occur when I use Windows 7 on the same computer and it stops killing the internet for other computers if I turn the download/Ubuntu off.

I am using an ASUS G74SX laptop running Ubuntu 12.10 with Gnome 3.6. My wireless card is an Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)

Thanks!

share|improve this question
    
Do you have any other computers or (more preferably) operating systems? Could you check whether the problem persists there also? Thanks :) (Welcome to Ask Ubuntu, too!) –  Mochan Dec 20 '12 at 6:44
    
@Mochan I also dual boot Windows 7 and the problem stops as soon as Linux is turned off. –  Travis Dec 20 '12 at 6:45
1  
I see, that's helpful. Have you checked your Internet settings? Check your MTU value. You can do that by going into 'Edit Connections...' via the indicator up top. You then click on your connection and check the value. I'll also add this as an answer. –  Mochan Dec 20 '12 at 8:05
    
My MTU is set to automatic. Is there something else it should be set to? –  Travis Dec 20 '12 at 8:09
1  
@david6 This is the info for my wireless card: Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67). It is a built in card. –  Travis Dec 20 '12 at 8:46
show 6 more comments

3 Answers 3

I don't know if this may be the cause/issue, but when I was using my brother's network, my laptop used to shut down his internet/network because of it automatically using 'Jumbo Frames'. The solution for me was to manually set my 'MTU' size. This can be easily done in the command line with:

sudo ifconfig eth0 mtu 1492

where you replace eth0 with the adapter, if you are using wireless you probably want to swap eth0 with wlan0. Or you can do it in your network manager seen here (change automatic to something like 1492, I believe jumbo frames are 9000):

enter image description here

share|improve this answer
    
unfortunately this fix did not have any effect. Thanks any way though! –  Travis Dec 20 '12 at 18:32
add comment

Likely cause:

Wireless performance issues on kernel 3.4.0-1-generic (iwlwifi)

Possible solution:

Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

and specifically post #3

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Note: More diagnostic details needed to confirm as likely cause ..

Try this command, and report results: (this will eliminate one possible cause)

lsmod | grep acer
share|improve this answer
    
this didn't not show any improvement. Still the same problem, internet works fine until I try to download anything. Also there was no output for any of these commands. Thanks for your help. –  Travis Dec 20 '12 at 18:43
    
I also went through the link your provided and tried some of the other solutions suggested and none of them seemed to work. –  Travis Dec 20 '12 at 19:21
    
What is the output from: lsmod | grep asus and lsmod | grep wmi ? –  david6 Dec 21 '12 at 8:25
    
The out put of lsmod | grep asus was : asus_nb_wmi 12710 0 asus_wmi 24088 1 asus_nb_wmi sparse_keymap 13890 1 asus_wmi wmi 19070 1 asus_wmi –  Travis Dec 21 '12 at 14:53
    
The out put of lsmod | grep wmi is : asus_nb_wmi 12710 0 asus_wmi 24088 1 asus_nb_wmi sparse_keymap 13890 1 asus_wmi snd_rawmidi 30512 1 snd_seq_midi snd_seq_device 14497 3 snd_seq_midi,snd_rawmidi,snd_seq wmi 19070 1 asus_wmi snd 78734 23 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,s‌​nd_rawmidi,snd_pcm,snd_seq,snd_timer,snd_seq_device –  Travis Dec 21 '12 at 14:55
show 1 more comment

Unless you have some form of bandwidth allocation manager on your router, that will happen every time. This will happen with every operating system. As long as your wireless card can handle equal to or greater than the amount of bandwidth as your router, your computer will try to snatch it all up.

If you're doing an HTTP download, I'd suggest getting the FireFox addon "DownThemAll" you're able to manage all of your downloads and allocate amounts of bandwidth to each of your active downloads, much like peer-to-peer sharing software.

There are also other things that can cause slow internet speeds such as: VOIP Phones (Vontage, Comcast, etc...), watching videos On Demand (Comcast, or something similar), and having your wireless router on the same channel as a nearby wireless network.

Another thing: It doesn't matter how your downloading things from the internet, the limit will always be the same, no matter how it's divided up. Say your bandwidth maxes out at 1mb/s, this could be 333.33kb/s updates, 333.33kb/s downloading ISOs, and 333.33kb/s watching YouTube videos.

share|improve this answer
    
Thanks for the answer! The problem I am experiencing only happens on Ubuntu 12.10, if I am on Windows 7 I can download things all I want with no problem on my, or anyone other, computer. The problem I am experiencing isn't just slow internet, whenever I try to download anything, it completely shuts down the internet for every other computer on my network. I have never had this problem before it only started happening within the past month, so I wouldn't expect it to be my bandwidth in the way you mentioned. And it has happened on multiple networks so it shouldn't be my router. –  Travis Dec 20 '12 at 9:20
    
If the question says it doesn't do this on another OS, it's kinda strange to start your answer with "it will happen with every operating system", don't you think? –  Nanne Dec 20 '12 at 9:27
    
I guess I didn't read it well enough. Generally when you have a program hogging up all of the bandwidth, it's program specific, not operating system. –  kelvinafox Dec 20 '12 at 9:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.