Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm following the tutorial following tutorial to get my Intel D2700DC motherboard's graphics working: http://daily.siebler.eu/2012/06/ubuntu-12-04-driver-for-intel-cedarview-atom-n2000-und-d2000-serie/

When I boot I'm getting a blank screen. I followed the tutorial and read all the comments. I've also tried:

Install gdm and use this instead of lightdm (ubuntu default)

sudo apt-get install gdm

Remove previous pae kernel: http://www.liberiangeek.net/2011/11/remove-old-kernels-in-ubuntu-11-10-oneiric-ocelot/

Reboot before adding cedarview packages.

Have tried with and without the video=LVDS-1:d to GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub.

I still get a blank screen. I am plugged into a HD screen through the HDMI and have tried the DVI connector also. I can see the grub menu, then a little of the loading and then 'No signal'. I can still ssh into the box though so it is logging in.

lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Intel Corporation Device 2011
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at 80100000 (32-bit, non-prefetchable) [size=1M]
    I/O ports at 20d0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: pvrsrvkm
    Kernel modules: cedarview_gfx


uname -a
Linux test-desktop 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:45:18 UTC 2012 i686 i686 i386 GNU/Linux
share|improve this question
add comment

1 Answer

The driver is available in the Ubuntu repositories, so no need to add PPAs. You can remove the PPA and the installed packages with

sudo apt-get install ppa-purge

sudo ppa-purge ppa:sarvatt/cedarview

Then install the driver.

Hope it works.

share|improve this answer
    
I've tried this and I get the same problem. I made sure I reinstalled the cedarview packages after I removed the ppa as well. –  map7 Dec 21 '12 at 0:48
    
Perhaps the problem is model related. Can you add the make and model of the notebook to the question. –  mikewhatever Dec 21 '12 at 1:05
    
It's a desktop motherboard: intel.com/content/www/us/en/motherboards/desktop-motherboards/… –  map7 Dec 24 '12 at 6:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.