Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install MATLAB on Ubuntu 12.10, I had it in my last laptop with 12.04 and I didn't have much trouble to install it.

I'm getting this problem:

j@jgb:~/Programs/Instaladores/matlab$ ./install
Preparing installation files ...
Installing ...
./install: 1: eval: /tmp/mathworks_1436/sys/java/jre/glnxa64/jre/bin/java: Permission denied
Finished

And it doesn't change if I change the permissions to the java file or to the install file as other posts say.

In my /etc/fstab file I had this line added (But nothing changes if I comment it): tmpfs /tmp tmpfs nodev,nosuid,noexec,mode=1777 0 0

Thanks

share|improve this question
add comment

3 Answers

I had the same problem. I tried installing the MATLAB R2012b.

The problem was the login name. Make sure you write the correct login name during the installation process, and its case sensitive.

I deleted the files and re-installed it and it worked.

Good luck.

share|improve this answer
add comment

You haven't give the install program permission to write the file /tmp/mathworks_1436/sys/java/jre/glnxa64/jre/bin/java

Try:

sudo install
share|improve this answer
add comment

Try to add the x permission to the "java" file

see ! it's easy ;)

http://tylau0.blogspot.com/2011/12/matlab-linux-install-error.html

share|improve this answer
    
He's not trying to execute the java file, the installer is trying to write it. –  fabricator4 Dec 20 '12 at 10:54
    
I got the same problem before and adding the x permission helped me. The install program needs to execute some java commands. –  Hakeem Wahab Dec 23 '12 at 2:44
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.